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Abstract 

Biological processes are the outcome of complex interactions between several elements 

in scales of time and space that are impractical, for the human eye, to understand. In 

Biomedical Engineering, a field of study that applies the concepts of exact sciences to 

medical problems, there is the need to understand, in detail, the physiological phenomena 

of human beings. With the amount of concepts to integrate, comes the inevitability of 

exploring educational tools out of the traditional setting. In recent years, there has been 

an increasing number of multimedia-based instructions, such as videos, computer 

modeling tools and digital laboratory scenarios, and many of its advantages are already 

known. The online sharing of these resources has been an important mean of knowledge 

dissemination, since it is possible to access it at any time, from anywhere. 

In this work, we sought to develop a platform that, based on scientific papers about 

modelling of physiological processes, introduces a theoretical approach about its 

concepts, through text or digital media, provides mathematical simulation contexts and 

shares remote and/or virtual laboratories related to the presented subject. This platform 

must allow the sharing and acquisition of knowledge and resources from and to the users, 

store all the data and be easy to operate. 

The result of this work, an online platform available on physio.dei.uc.pt, complies with 

the initial idealized requirements and its first test and validation was already made. Future 

work comprises the testing of the platform in an actual school subject context, in the first 

semester of the school year of 2016/2017, in order to evaluate its effectiveness near the 

students.  
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Resumo 

Os processos biológicos resultam de interações complexas entre diversos intervenientes, 

em escalas temporais e espaciais impraticáveis de observar ao olho humano. Em 

Engenharia Biomédica, área que aplica os conceitos das ciências exatas aos problemas da 

medicina, existe a necessidade de compreender, em detalhe, os fenómenos fisiológicos 

dos seres vivos. Com tantos conteúdos a integrar, surge, com frequência, a necessidade 

de ferramentas de ensino fora do cenário tradicional. Nos últimos anos, tem-se observado 

um aumento crescente de instruções multimédia no ensino, como vídeos, ferramentas de 

modelação computacional e cenários de experimentação prática digitais, sendo já 

conhecidas muitas das suas vantagens. A partilha destes recursos em meios online tem 

sido uma via importante de disseminação de conhecimento, dado ser possível o seu 

acesso, em qualquer altura, a partir de qualquer lugar. 

Neste trabalho, pretendeu-se desenvolver uma plataforma que, partindo de artigos 

científicos sobre modelação de processos fisiológicos, introduzisse uma abordagem 

teórica aos seus conceitos, através de texto e conteúdo digital, fornecesse contextos de 

simulação matemática e partilhasse laboratórios remotos e/ou virtuais relacionados com 

o assunto apresentado. Esta plataforma deveria permitir a partilha e aquisição de 

conhecimentos e recursos por parte dos utilizadores, guardar todos os dados e ser de fácil 

utilização. 

A plataforma resultante deste trabalho, disponível em physio.dei.uc.pt, cumpre com os 

requisitos inicialmente idealizados e a sua primeira fase de teste e validação já foi 

efetuada. No futuro a plataforma será testada em ambiente escolar real, durante o primeiro 

semestre do ano letivo de 2016/2017, de forma a avaliar a sua eficácia junto aos 

estudantes. 
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Chapter 1 

 

Introduction 

This project was developed in the Department of Informatics Engineering (DEI) of the 

Faculty of Sciences and Technology of the University of Coimbra, within the Biomedical 

Engineering Master's program, and in collaboration with the Centre for Informatics and 

Systems of the University of Coimbra. 

In this chapter, a brief overview of the developed work was made. Initially, the 

contextualization and motivation of this work are discussed. Then, the work plan is 

analyzed, by comparing the initial schedule and the real schedule. Furthermore, the 

structure of the thesis is presented with a short summary of what each chapter contains. 

Finally, the scientific contribution of this project is indicated. 

 

1.1. Contextualization and Motivation 

In physiological phenomena, what is noteworthy is usually a set of complex interactions 

between different elements, which can happen in extreme temporal and spatial scales, 

being impossible to observe in real-time events [1] [2] [3]. Thus, physiological processes 

cannot be truly apprehended without the understanding of biological functions in a 

macroscopic way, acknowledging the connections of its constituent parts, and in a 

microscopic way, knowing, in detail, its components [3].  

Biomedical engineering focuses on the analysis and problem solving in biological and 

medical contexts, by applying concepts of engineering and exact sciences. Consequently, 

there is, in this field, the need of a thorough comprehension of the physiological processes 
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of living beings. Even though the living systems are more complex than any highly 

advanced machine, multiple conceptions used in its development can be applied to mimic 

biological structures [4], existing a growing tendency to formulate analogies between 

physiological processes and fluidic, mechanical, electric and electromechanical models 

[5]. Given the massive amount of different areas and contexts to integrate in biomedical 

engineering, there is the need of educational methods out of the conventional settings.  

Furthermore, the rising number of students registered in biomedical courses requires the 

rationalization of teaching processes [6]. Even with the existence of tangible laboratory 

tools, there may not be time for each student to interact, freely, with them. Thus, 

multimedia resources can be a solution, both to overcome these difficulties, both to 

enhance the understanding of physiological processes in their different time and space 

scales [7].  

Computer modeling has also gained recognition as a tool in the perception of life sciences, 

given the complementarity between the mathematical power of abstraction and 

simplification and the realism of computational simulations [2] [3].  

The Internet has unquestionably changed the way we absorb and share information. 

Decades ago, the access to educational resources was restricted to schools and libraries, 

which caused time and displacement limitations. Currently, the Internet provides 

information in real time, at any hour and from any location with a connection. 

Consequently, e-learning platforms have become, through time, a more widely used 

approach to spread knowledge. Teachers and students both agree that e-learning improves 

the instruction and the learning processes [8]. 

Recently, there has been an emergent use of mobile technologies and many people see 

them as their first selection for connectivity [9]. Consequently, the use of tablets and 

smartphones may have an important role in e-learning, enabling learners to have their 

lessons anywhere, even in their dead times [10]. 
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1.2. Objectives 

In our work, we intended to create an e-learning platform to share and acquire knowledge 

about physiological processes. This platform shall provide biological/medical phenomena 

analysis and, based on scientific papers about modelling of physiological processes, 

allow: the allocation of theoretical approaches about its concepts, the support of 

computational simulations and the sharing of online experiments. 

In order to amplify the platform’s lifecycle and utility, it is desirable that it offers the 

possibility to upload content by users and, consequently, empower the enlargement of the 

scientific papers’ analysis’ repository.  

With the aim of making the platform accessible at any time, from anywhere, it must be 

available online and its access shall be conceivable from any device (e.g., personal 

computers, tablets and smartphones). 

The platform to be developed must also be built in a way that it can be used in Computer 

Models of Physiological Processes (CMPP), a subject of the Integrated Masters in 

Biomedical Engineering of the University of Coimbra. In this course, there is a semester 

project where the students analyze a scientific paper on mathematical modeling of 

physiological processes, simulating its computational model and discussing its theoretical 

foundations. 

 

 

1.3. Planning 

In this section, a comparison between the initial planned work time for each task, the 

actual consumed time to perform each task and the unexpected tasks that emerged and 

were not initially considered in the scheduling is presented (Figure 1.1). 
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Figure 1.1.: Initial scheduled vs. real scheduled. 

 

As seen in the Figure 1.1., the real scheduled work was composed by 12 tasks: 

 Definition of the work to be developed: At the beginning of the project, it was 

necessary to delineate goals, methods and formulate a work strategy; 

 

 Analysis of the state of the art covering online platforms: With the purpose of 

developing an online platform to act as a mean of knowledge spread, a detailed 
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exploration of e-learning platforms was required. This task was essentially the 

analysis of platforms focused on similar objectives; 

 

 Analysis of the state of the art covering digital representation of physiological 

processes: In order to create and share computer-based learning tools, an analysis 

of the current digital representation of physiological processes was crucial.  

 

 Identification of the characteristics to be implemented in the platform: 

Preceding the development of the platform, we identified the main general 

features to be implemented; 

 

 Identification of the characteristics of physiological models to be analyzed: 

At this phase, the key characteristics to approach in the exploration of the 

physiological processes’ models were identified; 

 

 Design of the platform: After all the core features were determined, the 

platform’s functioning requirements were pointed out and a prototype was built; 

 

 Learning about web development tools: For the purpose of building the 

platform, it was necessary to learn some web development concepts, in order to 

deal with technologies that I had never worked with before. This was a task that 

was not counted in the initial schedule, but that was decisive to proceed with the 

project. In this period, for example, I took part in an online course about 

“Responsive Website Basics: Code with HTML, CSS, and JavaScript” developed 

by the University of London, Goldsmiths, through COURSERA INC. [11]; 

 

 Development of the platform: At this stage, the platform was built, taking into 

account the desired features in the previously designed prototype; 

 

 Selection and analysis of the study cases: Some physiological processes’ 

models, as educational, illustrative and useful examples, were selected, explored 

and then shared in the platform; 
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 Writing of a scientific paper: The time spent on writing a scientific paper, later 

accepted, was also not taken into account in the first work planning. This task 

included the time of idealizing and writing the scientific paper; 

 

 Test and validation of the platform: This task consisted in putting the platform 

to be used by real users and in the collection of their opinions; 

 

 Writing of the final report: At the end, the final report of the project was written. 

 

There were some differences between the original schedule and the real work strategy. 

The greatest challenge to solve, but also the personally most pleasant achievement, was 

the need to deal with tools and technologies that I had never used before. However, the 

initial objective was achieved and the platform was developed as planned. 

 

 

1.4. Document Structure 

The structure of the document is organized as follows: in Chapter 2, it is investigated the 

state of the art and the educational contribution of computer-based representations of 

physiological processes; in Chapter 3, an approach about e-learning is made, and some 

online platforms with focus on life sciences are explored; in Chapter 4, it is formulated 

the design of the platform to be built; in Chapter 5, it is described the development of the 

platform; in Chapter 6, the study cases to be inserted in the platform are chosen and 

studied; Chapter 7, reports the results of the test and validation of the platform; as a final 

point, in Chapter 8, the final results and the proposals for future work are presented. 
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1.5 Scientific Contribution 

The work entitled “Development of an E-learning Platform for Storage, Simulation and 

Online Experimentation of Models of Physiological Processes”, elaborated in the scope 

of this project, was accepted in the special session “Talking About Teaching 2016” of the 

“International Conference on Interactive Collaborating Learning 2016”, which will take 

place in Belfast, United Kingdom, in September 2016. 
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Chapter 2 

 

From Physiology to Computational 

Representation 

 

2.1 Physiological Processes: An Overview 

Physiology, a subdivision of biology, focuses on the quantitative understanding of the 

multifaceted behavior of living beings [12] [13]. It covers a range of topics that comprises 

biological compounds, cells, tissues and organs, and how they connect to make life 

conceivable [14].  

 

2.1.1 Complexity of the Analysis of Biological Systems 

In biological contexts, what is important is usually a set of relations between elements of 

a system. Given the enormous complexity of living organisms, compounded by the 

presence of external agents in very short of very large contexts of time and space, the 

human capacity to understand these processes is very limited [1] [2] [3]. – e.g., for the 

human body, temporal scales can range from 1 µs (ion channel gating) to 109 s (human’s 

lifetime) and spatial scales can range from 1 nm (protein) to 1 m (whole body), which 

means 16 and 10 orders of difference between magnitudes, respectively [3].  
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Physiology cannot be understood without the perception of biological phenomena neither 

in a macroscopic way nor in a microscopic way. To recognize how the living systems 

work, a clear comprehension of all interactions of the evolved components is needed, and, 

at the same time, a precise conception of their constituent parts [5]. 

Thus, a proper knowledge of the biological functions arises only if we are able to combine 

all the information in all points of organization [3]. For example, in the case of the 

ingestion of a drug, it is not only important its effects on the target, but all its course and 

interactions. Without this awareness, the drug could potentially lead to dangerous side 

effect that would not be acknowledged [1] [3]. In the case of tumor formation, in addition 

to understand its growing, it is crucial to realize several processes that occur at the same 

time and that may play a central role on wound healing, for example [15].  

 

2.1.2 Use of Modeling in Physiology 

According to [16], a model can be described as a “construct invented as an aid to 

understand a specific system under study, and possibly the relationships of that system 

with other systems”.  

In all sciences, models are used to represent in a simplified way a more complex reality, 

embodying the essential and interesting aspects of the reality. These are very important 

as learning tools, once they make the subject more familiar and accessible and ease the 

formulation of intuitive descriptions. Any abstraction of a biological event can be 

considered a model [2]. 

A mathematical model is an abstract model that is defined by a set of equations and 

expresses the behavior of a system [16] [17]. The formulation of mathematical models 

that describe biological processes of great complexity and dynamism are very important 

to understand physiological functions, mainly because this models can take into account 

the multiple spatial and temporal contexts in which the processes occur. Such extreme 

scales lead to the need of a joined hierarchy of models for the perception of those systems 

[3]. For the study of large systems, the most known and reliable mathematical technique 

is the use of differential equations [18].  
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2.2 Computational Simulation of 

Physiological Processes 

Generally, the mathematical models resulting from the analysis of biological processes 

are so complex that they can only be solved computationally, which increases the 

importance of computer simulations [3]. 

A computer simulation can be defined as a “program that is run on a computer and that 

uses step-by-step methods to explore the approximate behavior of a mathematical model” 

[19]. Widely, computer simulations can be seen as simpler approaches to understand 

processes, which includes: the choice of a model, the decision of how to implement it on 

a computer, the calculation of the algorithms’ output and the analysis of the results [19]. 

In general, dynamic interactions in biological systems take place in temporal and spatial 

scales that are impossible to observe. One of the only feasible approaches to understand 

complex connections between physiological processes is through the performance of 

computational simulations based on previously developed mathematical models [3]. 

Generally, a computational model replicates the behavior of a system, overcoming the 

length scales concerns and incorporating multiple concepts [20].  

Biomedical sciences have been experiencing an enormous revolution, with increasingly 

more discovered data and explored materials, and, therefore, more information to 

integrate [3]. Thus, the current amount of collected information is beyond the capability 

of any human to analyze. To understand and explore these data, modelling simulations 

are essential [2].  

Moreover, computational simulations can be performed in real-time and allow the 

analysis of different contexts and the changing of parameters, getting results faster than 

using any other approach [2]. 
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2.3 Remote and Virtual Experiments in 

Biomedicine 

Students in biology fields are constantly filled with new information, theories, techniques 

and vocabularies, which are essential to learn and discuss the mechanisms of biological 

phenomena. Still, the unsophisticated act of learning by rote is progressively becoming 

outdated and there is a growing tendency to absorb knowledge through exercise, 

particularly through the use of practical experiences that demonstrate biological 

principles. These scenarios create a learning environment that stimulate students to 

critical thinking [21].  

Science teachers claim, since the 19th century, that practical activities are an important 

mean of instruction [22]. Through the use of laboratories, students can be encouraged to 

inquire and investigate, improving their sense about certain concepts and understanding 

how science is made and how the facts are discovered [22]. 

At the present, even with the existence of physical laboratory spaces, the opportunity for 

each student to interact freely with it might not exist. Beyond this, the use of these 

laboratories is only accessible to students usually once, in short periods of time (as the 

time of a single class lecture). Besides, there are still many isolated locations without any 

or poor access to laboratory equipment. In those cases, there is a great need for 

alternatives that compensate that lack. 

Remote experiments can be termed as structures based on real equipment that allows 

students to execute practical work through a computer remotely linked with it, (e.g., 

through an internet connection) [23]. Many of their advantages are: these practical 

experiments can be accessed 24 hours per seven days, without any supervision and, 

through the use of automated management systems, users can be assigned to time limits 

during busy periods, ensuring that everyone has a chance to execute the experience [24]; 

given that a public access and an actual physical interaction with the experiment are not 

needed, the equipment is less likely to be damaged, vandalized or stolen [24]; although 

the remote experiments are handled by computer, they retain the characteristics of a real-

time physical experiences, returning real experimental results. 
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A virtual experiment can be defined as a virtual studying and learning environment in 

which is possible to conduct an experiment [25] [26]. Many of the benefits of the remote 

experiments can be applied to virtual experiments. In virtual environments, although we 

are not dealing with a real physical context and real experimental outputs, there are other 

advantages, such as the possibility to represent scenarios in non-real scales, in order to 

facilitate the understanding. Moreover, these scenarios can be accessed by several users 

at the same time. With the power of technology, it is now possible to create great user 

interaction and a plausible manipulation of objects and parameters [27]. Furthermore, 

studies show that the use of virtual experiments increases students’ learning levels [28]. 

In this way, remote and virtual experimental scenarios can play a fundamental role in the 

learning of concepts in the field of biology. 

 

 

2.4 Summary 

In this chapter, some of the current difficulties in the analysis of physiological processes 

(and how they may be overcoming) were discussed. It approaches the role of modeling 

and mathematical modeling in the study of biological phenomena and in what manner 

computer simulations can be a key element in the understanding of these concepts. 

The importance of experimental scenarios in the field of biology was also reviewed. 

Given the limitations of physical access to this type of equipment, remote and virtual 

experiments can be considered as a solution. 
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Chapter 3 

 

E-learning in Modern Education 

In this chapter will discuss the advantages and the challenges of e-learning, as well as its 

blend with traditional education. We will also explore some selected e-learning platforms 

and analyze their features of interest. 

 

3.1 E-learning: definition 

E-learning can be defined as the usage of electronic technologies to access educational 

resources [29]. Traditionally, it has been considered two types of e-learning: distance 

learning, which is the use of technologies to provide lessons in remote locations, and 

computer-based learning, which is the use of computers to support multimedia learning. 

Nowadays, with the popularity of the Internet, these two definitions became integrated 

inside the characterization of e-learning [8].  

In recent years, education delivery has been under a tremendous revolution [30]. Blogs, 

wikis, virtual environments and social networks have been gaining an increased use in 

higher education [31]. Wikis are termed as server software that allows users to collaborate 

on the forming of websites (e.g., accept the insertion of content) [32]. 

The benefits and adversities of e-learning have been widely discussed and investigated. 

Its effectiveness has also been tested when combined with traditional teaching settings. 
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3.1.1 Advantages 

Computer-based teaching empowers learning to be more individualized (adaptive 

learning) and, at the same time, stimulates learners’ connections with others 

(collaborative learning), placing apprentices in control of their own tuition. Through e-

learning, there is generally an increased accessibility for the user to find what he requires, 

at any time. This appears to be crucial, once learning is often an unexpected practice [8].  

It is usually easier to renew digital media than on paper material, which facilitates and 

accelerates the sharing of updated knowledge. [8] [33]. In addition, Internet offers a faster 

and expanded spread of information, allowing the discovery of subjects beyond the limits 

of a book [8] [31] 

Students tend to learn more through e-learning than with traditional teaching settings, 

presenting higher retention rates and greater acquirement of knowledge [8] [34]. 

Interactivity acts as a major part in this occurrence, leading to more intellectual 

commitment. In computer-based instruction, it is possible to stop, repeat and reflect, 

consenting the user to focus on his own doubts [34]. Web-based technologies offer a 

massive learning flexibility. In this environment, learners can move at their own pace and 

control their learning sequence [8] [33]. These can be some of the reasons why, when 

faced with computer-based tuition, students learn often in less time than with other 

learning approaches. This one-to-one involvement removes, for example, the time 

waiting for other colleagues’ doubts to be answered, as in a classroom, allowing the 

learner to concentrate only in his own questions. Time saved can vary from 30% to 60% 

[34]. 

This self-control can also contribute as a motivating element. If the learner has the option 

to decide when and how to learn, learning might be more substantial. Furthermore, the 

absorbed knowledge is more significant when the student is in the mood to study [34]. 

One of the most obvious advantages of e-learning is that it defeats physical distances, 

reaching the most isolated places [33]. This can be very helpful, for example, to share 

online experimental scenarios that may not be available in those locations. Besides, even 

with the existence of tangible laboratories, online experiments may still be useful, once 

they allow an individualize contact and the possibility of repetitions [6] [7].  
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Smartphones and tablets have become increasingly more popular [9]. Given its easiness 

of use and the fact that people are usually carrying one, e-learning is an amazing 

opportunity to spread knowledge, allowing the delivery of information at any time, even 

during other activity breaks or waiting times (dead times) [10]. 

 

3.1.2 Challenges 

Although digital technology apparently facilitates the learning process, it is still difficult 

to truly understand its effectiveness and accurately assure that an appropriate learning is 

achieved [31]. Moreover, the elaboration of effective online laboratories can be very 

expensive and, regardless of the best plans, technical problems are always inevitable [33]. 

Despite the evidences that show that an individualized study can be an advantage, this 

can lead to social isolation. Even with the involvement on discussion forums, it still is a 

different kind of community integration, compared with face-to-face debates [33]. 

Nowadays, the learning process is still very much linked to personal communication: eye 

contact, tone of voice and body language are essential, once the brain requests and expects 

these channels of interaction [30].  

 

3.1.3 E-learning Combined with Traditional Education 

A relatively recent new term in the education field is blended learning [8]. According to 

[30], blended learning can be described as “the combination of face-to-face instruction 

with online platforms”. In this context, teachers will no longer act primarily as providers 

of content, but will become more focused on facilitating the learning process and behave 

as evaluators of competency [8]. Students do not see e-learning as a replacer of traditional 

educational methods, but a supplement [8] and an “expected and integral part of the 

learning process” [35]. Through the use of computer-based instruction, teachers can focus 

on the support, motivation and help of the students, instead of delivering “repetitive stand-

up training” [34].  

Over the past decades, institutes of higher education have been embracing blended 

learning, merging the greatest characteristics of real and virtual environments [35]. With 

blended learning it is possible to experience the benefits of e-learning and overcome quite 
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a few of its disadvantages. Summing up, with blended learning it is possible to combine 

“the potentials of web-based training with those of classroom techniques” [30]. 

Both benefits of face-to-face communication and the power of e-learning are 

incontestable. Their complementarity can generate an extremely solid learning method 

[30].  

 

 

3.2 Biomedical E-learning Platforms 

In the last few years, e-learning platforms have amplified its attractiveness, arising several 

alternatives, appearing several options, such as theoretical approaches based on digital 

media, computational modeling tools and online laboratories. 

In the subsequent topics, we will explore some e-learning platforms with a focus on the 

life sciences. 

 

3.2.1 hhmi|Biointeractive 

hhmi|Biointeractive [36] is an online platform developed by the Howard Hughes Medical 

Institute. The main goals of this platform are to provide free and up-to-date education 

resources to the teachers and to stimulate students to be curious and passionate about 

science [37]. Some of the resources we can find at hhmi|Biointeractive are short films, 

virtual laboratories, interactive tutorials, classroom resources and teacher guides [38]. For 

the common use of the platform, there is no need to register. However, there is the 

possibility of ordering materials and, in that context, registration is required. 

In the platform’s homepage (Figure 3.1), we are able to do a free search, a search by 

topics, a search by resource types (e.g., video, interactive media, short courses) and a 

search by collections; we can also observe the team suggestions and the most popular and 

newest content [36].  
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Figure 3.1: hhmi|Biointeractive homepage [36]. 

 

When we select a resource (e.g., Figure 3.2), there is a brief overview of the subject. In 

many cases, it is possible to download materials such as worksheets, theoretical 

explanations, videos, among others. Some of the materials are available as applications 

for smartphones. 

 

 

Figure 3.2: Example of a resource of hhmi|Biointeractive [39]. 
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3.2.2 Virtual Labs 

Virtual Labs [40], an initiative of the Ministry of Human Resource Development of the 

government of India under the national mission on education through information and 

communications technologies, offers numerous virtual/remote laboratories and 

simulation environments, among others, in multiple areas of science and technology. This 

project aims to create online experimentation environments that can overcome the 

difficulties of geographical and equipment constraints, as well as sharing an assortment 

of learning tools, in a way that can create enthusiasm and interest in the students. 

The Virtual Labs initiative has several participating institutes. When we choose a 

scientific/technology field to explore (e.g., Biotechnology and Biomedical Engineering) 

and the concrete resource to be investigated, we are redirected to the institution that is 

hosting the experiment environment. In this context, for a total access of the materials, 

depending on the host platform, it may be necessary to create an account. 

Depending on the selected subject, the presented type of resources (e.g., video, 

animations, simulations, virtual and/or remote laboratories) varies; sometimes, there is 

the possibility of downloading materials and, if the context suits, it is possible to export 

the data obtained.  

 

 

Figure 3.3: Example of a resource of Virtual Labs [41] [42]. 
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In the example showed above (Figure 3.3) there is a mathematical simulator [41], an 

animation with a virtual laboratory [42] and the possibility to download MATLAB files 

[43]. Although some aspects change depending on the selected subject, there are, in all 

the areas I searched, a theoretical approach and a self-evaluation task. 

 

3.2.3 The Biology Corner 

The Biology Corner [44] is an online platform created by Shannan Muskopf, a teacher at 

Granite City High School, with a Bachelor’s degree in Biology and a Master’s degree in 

Educational Technology [45].   

In the homepage (Figure 3.4), there is the possibility to choose the content by its topic 

and resource type, as well as to observe the most popular and newest lessons [44].  

 

 

Figure 3.4: The Biology Corner homepage [44]. 

 

The platform contains several lessons (as Figure 3.5), quizzes, online laboratories, 

webquests and theoretical information on a variety of topics. 
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Figure 3.5.: Example of a lesson of The Biology Corner [46]. 

 

Some of the resources that are presented are not hosted in The Biology Corner and, when 

we select them, we are redirected to the host webpage; however, in those cases, this 

platform gives us a detailed explanation of how they will work (Figure 3.6).  

 

 

Figure 3.6: Example of an explanation of a resource hosted in another web platform [47]. 

 

At The Biology Corner, there is no option for creating an account, being the navigation 

completely free. 
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3.2.4 PhET Colorado Interactive Simulations 

PhET Colorado Interactive Simulations [48], a project at the University of Colorado 

Boulder, was founded by Nobel Laureate Carl Wieman. This platform shares interactive 

math and science simulations, based on extensive education research, with the purpose of 

stimulating students through a learning environment of exploration and discovery. Those 

simulations are written in Java, Flash and HTML5 and can be ran online or downloaded 

for free [49].  

 

 

Figure 3.7: PhET Interactive Simulations’ Biology Separator [50]. 

 

When we opt for an area to explore, the platform shows the simulators related to that field 

and the language in which they were written. Clicking in a specific simulator (Figure 3.8), 

we are allowed to download it, as well as embed it in our own website, and read some 

information about the content, software requirements and credits. 
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Figure 3.8: Example of a simulator at PhET Colorado Interactive Simulations [51]. 

 

In addition to the simulations, resources target to educators are also available. In this 

context, it is possible to share teaching activities, which requires a previously registration 

in the platform. 

 

3.2.5 Wisc-Online 

Wisc-Online [52] is an online platform created by sixteen colleges in the Wisconsin 

Technical College System and it is maintained by the Fox Valley Technical College [53]. 

Its purpose is to offer free quality education materials that condense the information into 

small segments easy to understand, giving users the possibility to choose what to learn, 

at their own step.  

Selecting the field of Life Sciences [54] (Figure 3.9) we can choose to observe the content 

by its rating, name, views and updated date. The resources types vary among videos, 

animations and educational games and others.  

When we pick a specific learning object [55] (Figure 3.10), in addition to have access to 

the material, we can download a copy of it. Also, we can leave a question, start a 

discussion and see related resources.  
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Figure 3.9: Wisc-Online Life Sciences' main page [54]. 

 

 

 

Figure 3.10: Example of a Wisc-Online learning content [55]. 

 

It is also possible the creation of our own educational game [56] (Figure 3.11) which can 

be played in any device. For the general access to the contents, a registration is not needed; 

however, to download and update materials, it is necessary an account or a log in through 

social media. 
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Figure 3.11: Wisc-Online game builder [56]. 

 

 

3.2.6 Features’ Analysis 

After a detailed exploration of the platforms described in 3.2.1, 3.2.2, 3.2.3, 3.2.4 and 

3.2.5, we summarized and evaluate the existence of a set of features, described below. 

The remaining references in this document to those features will be made in accordance 

to the concepts described below (with the assigned definitions). 

 Computational Simulations (1): real-time computer simulations of 

mathematical models, displayed as graphics or tables; 

o Interactive (1.a): when there is the possibility of varying initial conditions 

or other parameters; 

o Non-Interactive (1.b): when all the parameters are fixed; 

 Virtual Experiments (2): multimedia contexts that implement a practical 

experiment or display an animated physiological perspective; 

o Interactive (2.a): when there is the possibility of changing parameters or 

interact with the experiment; 

o Non-Interactive (2.b): when all the parameters are fixed and no 

interaction is available; 

 Remote Experiments (3): physical remote laboratories that implement a practical 

experiment; 
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o Interactive (3.a): same as 2.a; 

o Non-Interactive (3.b): same as 2.b; 

 Registration (4): creation of a user account; 

o Optional (4.a): when the registration is optional and it is possible to use 

most of the features of the platform without it; 

 Free (4.a.i): when the registration is free; 

 Paid (4.a.i.i): when the registration is paid; 

o Required (4.b): when it is not possible to interact with core functionalities 

without an account; 

 Free (4.b.i): same as 4.a.i.; 

 Paid (4.b.ii): same as 4.a.ii; 

o Depending on external entities (4.c): when the necessity of an account 

depends on external entities; 

 Content Upload (5): option to upload content; 

 Content Download (6): option to download content; 

o Theoretical Material (6.a): (e.g., theoretical reading files); 

o Practical Material (6.b): (e.g., simulation files, virtual experiments); 

o Multimedia Files (6.c): (e.g., audio, videos, images); 

o Export of generated data (6.d): (e.g., graphics or tables generated in 

simulations or experiments); 

 Mobile Devices (7): possibility of access content through a mobile device; 

o In the form of an app (7.a): when the content is available as an 

application for download for mobile devices; 

o Optimized to mobile devices (7.b): when the platform is responsive and 

can be accessed with quality from a mobile device; 

 Content’s Approach (8): address a review of the offered content; 

o Theoretical Lectures (8.a): theoretical elucidations of the presented 

topic; 

 Text Documents (8.a.i): when it is presented in the format of a 

text; 

 Multimedia Files (8.a.ii): when it is presented in a digital format 

(e.g., audio, videos, images); 
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o Critical Analysis of the References (8.b): critical inquiry of the matter 

of the references; 

o Evaluation Activities (8.c): tasks and quizzes to evaluate the knowledge 

of the user in the subject; 

o Critical Reviews and Debate (8.d): possibility to introduce questions, 

reviews and/or start a debate; 

 User’s Feedback (8.d.i): possibility to rate an existing content or 

leave an opinion; 

 Discussion Forums (8.d.ii): existence of debate forums where is 

possible to start a conversation; 

Table 3.1 presents an analysis of the existence of the previously defined features in the 

explored platforms; the last column represents the features that arouse more interest and 

are more appealing to include in the platform to be developed. 

Table 3.1.: Analysis of the described platforms and the selection of the features of greater interest. 

 
hhmi| 

Biointera-

ctive 

Virtual 

Labs 

The 

Biology 

Corner 

PhET 

Colorado 

Interactive 

Simulations 

Wisc- 

-Online 

Features of 

greater 

interest 

Computational 

Simulations 
 1.a, 1.b    1.a, 1.b 

Virtual 

Experiments 
2.a, 2.b 2.a, 2.b 2.a, 2.b 2.a, 2.b 2.a 2.a, 2.b 

Remote 

Experiments 
 3.a, 3.b    3.a, 3.b 

Registration 4.a.i 4.c  4.a.i 4.a.i 4.a.i 

Content Upload    5 5 5 

Content 

Download 
6.a, 6.c 6.b, 6.d 6.a 6.a, 6.b, 6.c 

6.a, 6.b, 

6.c 

6.a, 6.b, 

6.c, 6.d 

Mobile Devices 7.a, 7.c  7.b  7.b 7.b 

Content’s 

Approach 

8.a.i, 8.a.ii, 

8.c, 8.d.i 

8.a.i, 8.a.ii, 

8.c, 8.d.i 

8.a.i, 8.a.ii, 

8.c, 8.d.ii 

8.a.i, 8.a.ii, 

8.c 

8.a.i, 

8.a.ii, 

8.c, 8.d.i, 

8.d.ii 

8.a.i, 8.a.ii, 

8.b, 8.d.i, 

8.d.ii 

 

It is important to refer that the previous analysis of the explored platforms considers what 

was found in the quest and, once the platforms have not been observed in the absolute 
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totality of its content, given its breadth, there is the possibility of them to contain 

characteristics not recognized in Table 3.1. 

 

 

3.3 Summary 

Through this chapter, we realize that e-learning is gaining popularity and, despite its 

current challenges, many of its advantages are already recognized. In addition, blended 

learning, a learning strategy that combines traditional education scenarios with e-learning, 

is also increasing its attractiveness, by merging the benefits of both methods. 

Furthermore, we analyzed some e-learning relevant platforms and explored its main 

features and characteristics of interest.  

  



30 

 

 

 

  



31 

 

 

 

 

 

Chapter 4 

 

Platform Design 

In this chapter will be discussed the characteristics and desired features to be included in 

the platform of this project. We will also develop a prototype of its navigation structure 

and its general appearance. It will also be discussed tools that may facilitate the 

construction of the system. 

 

4.1 Overview 

The solution to be developed is an e-learning platform that supports the sharing and the 

acquiring of knowledge in the physiological field. This platform, having scientific articles 

as reference, shall allow the introduction of theoretical analysis about the subject, the 

share of multimedia materials, the performing of computer simulations and the allocation 

of available online laboratories. To increase the platform’s longevity, it shall be possible 

to upload examinations and resources. In this way, to ensure the significance and the 

constraints of the shared materials, there shall be different levels of users, including a top 

level, that must moderate the inserted content. However, not all the introduced material 

needs to be completely precise and proven; consequently, it is crucial to provide feedback 

and discussion means, allowing critical debates from other users. The platform shall be 

completely free and available on any device. 
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4.2 Requirements’ Analysis 

The Requirements Analysis can be described as the identification of the features and the 

functionalities that shall be presented in a system [57], which can be divided into 

functional and non-functional requirements [58]. Functional requirements define what the 

system shall offer to the users. Non-functional requirements focus on matters such as 

constraints, targets and/or control mechanisms (e.g., different user levels) [59]. The 

MoSCoW Method was used to classify the priority of each requirement. This method 

ranks queries in four levels [60]:  

 MUST (M): Must have this requirement to the success of the system;  

 SHOULD (S): Should have this requirement, but the success of the system does 

not depend on it;  

 COULD (C): Could have this requirement, if it does not harm other parameters 

in the project;  

 WOULD (W): Would like to have this requirement, but it is considered as future 

work. 

In the subsequent sections, the functional and non-functional requirements of the platform 

are listed, grouped by their context, and classified according to the MoSCoW method. In 

order to ease the future references to the requisites, an ID was assigned to each 

requirement.  

 

4.2.1 Functional Requirements 

To allow an effortless and simples use of the platform, search engines that return articles 

(and articles’ analysis) from the database must be available. 

Table 4.1: Search Requirements. 

ID Search Category 

S.1 The website allows the user to search through default topics. M 

S.2 
The website allows the user to search through natural language, 

returning content that match the inserted words. 
S 

S.3 
The website’s homepage suggests some articles (e.g., the most 

viewed). 
C 
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Authentication is a key point in the system, since it ensures the privacy of content and the 

protection of data. Each account is associated with credentials that are described below.  

Table 4.2: Authentication Requirements. 

ID Authentication Category 

A.1 
Each user has a name, username (unique identifier), password 

and e-mail address (unique identifier). 
M 

A.2 
A logged-out user has to enter his credentials in order to access 

his account. 
M 

A.3 A registered user is able to remain logged-in into the website. C 

 

The platform must allow the insertion and handling of content through easy-to-use 

management tools. 

Table 4.3: Management of Articles Requirements. 

ID Management of Articles Category 

MA.1 Creation/edition/deletion of an article’s analysis and its content. M 

MA.2 Approval of submitted analyses. M 

MA.3 

In each article’s analysis, the website is prepared to accommodate 

text, multimedia files and web development languages (HTML, 

JavaScript and PHP), as well as embed other websites’ 

pages/contents. 

M 

MA.4 

For each article’s analysis, the user has total freedom to insert any 

sections, in the form of tabs (e.g., theoretical approaches, 

computational simulations, practical experiments, download 

options). 

S 

MA.5 Observation of own submitted articles (approved/ unapproved). S 

MA.6 

There is, at least, one entity responsible for the control and 

management of all article’s analyses, being able to edit all their 

parameters. 

M 

 

The platform must allow the insertion and handling of users and their parameters through 

easy-to-use management tools. 
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Table 4.4: Management of Users Requirements. 

ID Management of Users Category 

MU.1 Creation of a new account. M 

MU.2 
Any account is associated with a name, username (unique 

identifier), password and e-mail address (unique identifier). 
M 

MU.3 
A new account becomes activated after an e-mail confirmation 

(the e-mail is automatically sent by the website). 
S 

MU.4 
All the account parameters can be edited, except username and 

status. 
S 

MU.5 
There is, at least, one entity responsible for the control and 

management of all users, being able to edit all their parameters. 
M 

 

The system must provide discussion forums and the possibility for users to give feedback. 

Table 4.5: Feedback and Discussion Requirements. 

ID Feedback and Discussion Category 

FD.1 The website includes a discussion forum. M 

FD.2 The reading of the discussion forum is possible. M 

FD.3 
The start of new topics of discussion in the forum and the 

participation in a previously created one are possible. 
M 

FD.4 
A rating system, in every inserted article’s analysis, is available 

and the mean of the given responses is showed. 
S 

 

 

4.2.2 Non-Functional Requirements 

The platform must be responsive and capable of being displayed in the most used 

browsers. 

Table 4.6: Browser and Responsiveness Requirements. 

ID Browser and Responsiveness Category 

BR.1 
The website is available in the most popular browsers (Chrome, 

Internet Explorer, Firefox and Safari) [61]. 
M 

BR.2 The website is responsive. M 

 

All the actions available in the system must be accessible through the front-end, in an 

organized and orderly way.  
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Table 4.7: Interface Requirements. 

ID Interface Category 

I.1 The website has a user-friendly interface. M 

I.2 All the features are available through the front-end. M 

I.3 The content is organized in a hierarchical way. M 

I.4 The names of the sections are clear. M 

I.5 The aspect of the website is consistent and clean. S 

 

A help section should be available, containing documentation guides. After the 

performing of an important action, a notice message shall be displayed. 

Table 4.8: Help Requirements. 

ID Help Section Category 

I.1 
A documentation guide, including a detailed explanation about 

how to operate the functionalities of the website, is available. 
M 

I.2 
A proper message is displayed, when any 

creation/edition/deletion action is performed. 
S 

 

 

4.2.2.1 User Levels 

The platform must have three levels of users: guests, authors and super users. Guests are 

public users that are not registered into the website; on the other hand, authors and super 

users are both registered users. When a new account is created, the user’s group is, by 

default, defined as an author. 

Only some of the functional requirements, discussed in Section 4.1, must be reachable to 

all the users. In Table 4.9 and Table 4.10 the functional requisites with special access that 

must be accessible only to registered users and super users, respectively, is approached in 

more detail. 
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Table 4.9: Registered Users Special Accesses. 

ID Category Functional Requirement 

MA.1 M 
Registered users are able to create an article’s analysis, and 

edit/delete it. 

MA.4 S 
Registered users have total autonomy in the choice of the sections 

(tabs) to be inserted/examined in an article’s analysis. 

MA.5 S 
Registered users can observe their own submitted articles – both 

approved and unapproved. 

MU.4 S 
Registered users are allowed to edit all their account parameters, 

except their username and status. 

FD.3 M 
Registered users can start a new discussion topic in the forum. 

They can also participate in an existent one.  

 

Table 4.10: Super Users Special Accesses. 

ID Category Functional Requirement 

MA.2 M An analysis stays pendent until a super user’s approval. 

MA.6 M 
Super users have full control in all the inserted content, being able 

to edit/delete it and change their publishing state. 

MU.5 M 
Super users are able to see all the user’s parameters, except for 

their passwords, and edit his data, including their user group.  

 

Super users must, in addition, be allowed to see some statistics of the website, such as its 

number of visitors. 

 

 

4.3 Conception of a layout 

A layout can be defined as the initial design of a project and shall be used as a reference 

in its development. It must include all the major details to be incorporated in the final 

version [62].  

In the following section, the website’s structure and wireframes will be elaborated.   
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4.3.1 Structure Diagram 

A structure diagram is a scheme model used to document the different elements of a 

system and how they connect. It is a useful guide tool in the design of a project, given 

that it helps to understand how the elements of a system must interact and to ensure the 

relationship of all the parts [63].  

The platform to be built must have three different levels of users, with different accesses. 

The structure diagram (Figure 4.1) takes into account the permission of each user.  

 

 

Figure 4.1: Navigation diagram of the platform. 

 

The platform to be developed shall contain a hidden menu, accessible from any page, that 

allow: the contact with the forum, the personal account, the creation of an analysis, the 

management of own submissions, the user manager, the article manager and the settings 

options, taking into account that the visibility of those actions follows the diagram above. 

It shall also have a sticky header, present on every page, giving access to the homepage 

and the search for topics.  



38 

 

 

 

The homepage must provide access to: a natural language search engine, a search by 

topics and a window of suggested articles' analyses (presenting the most recent and the 

most popular ones), enabling the navigation through all the platforms' contents. After 

performing a search, we are conducted to a page with the search results. Selecting one of 

the results, we are sent to its content, which may vary. Examples of the analyses’ topics 

may be theoretical approaches, computer simulations and online experimental 

laboratories.  

 

4.3.2 Wireframes 

The drawing of wireframes is a very important step in the development of websites, 

because they display the skeleton of the pages, through two-dimensional visual 

representations of the website's interface [64] [65] [66].  

Using MockFlow [67], a few wireframes were created, which are shown below. 

As aforementioned, on the homepage (Figure 4.2) there shall be a free search engine and 

suggestions of analyses to read, such as the most viewed and the newest. 

 

 

Figure 4.2: Homepage’s prototype. 

 

As referred, there must be a hidden menu available through any page (Figure 4.3), 

containing essential links. This menu will allow the reaching of important features, such 
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as the management of users and inserted analyses, as well as main website settings. It 

shall also be possible to introduce an article’s analysis, visualize own submissions and 

consult/edit account parameters. The access to the discussion forum must also be 

achievable.  What appears in the hidden menu must be in accordance to what was defined 

in Figure 4.1. 

 

 

Figure 4.3: Example of the hidden menu, viewed from a super user, available from any page. 

 

A login option must also be present in all pages. Through this link, it is possible to create 

a new account.  

 

 

Figure 4.4: Login's prototype. Through this page, it is also possible to create an account. 
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After a search by topics, the results that meet the requested field shall appear. It shall also 

come into view a side menu, with the subtopics of the researched theme.  

 

 

Figure 4.5: After a search by topic, the results must be shown and the subtopics of the main topic must 

appear in a side menu. 

 

Super users must have access to a special page where they can view all the submitted 

analyses and approve, edit and delete them. 

 

 

Figure 4.6: Prototype of the "Article Manager". 
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The contents of the analyses may vary, depending on the intents of its creator. For 

example, it can integrate theoretical approaches, computer simulations and practical 

experiments. 

 

 

Figure 4.7: Example of an article's analysis. A computational simulation can be seen as an example. 

 

 

4.4 Development Tools 

In order to ease the construction of the platform, several tools were considered. Given the 

defined requirements and characteristics to build, we decided that a Content Management 

System (CMS) would be a good solution. 

The following subsections are to discuss and chose which CMS would be better to 

construct the project. 

 

4.4.1 Content Management System 

A CMS can be defined as a software application that is used to create and control digital 

content [68].  
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The three more popular and free CMS are WordPress, Drupal and Joomla!, offering many 

features and strong security [69]. All the three are written primarily in PHP, support 

MySQL and use themes and extensions to lengthen their features [70]. 

WordPress is the most popular CMS in the world and, for beginners, it may be the best 

choice. Drupal is one of the most powerful open source options available, which comes 

with an increase in the complexity of use. Joomla! can be considered a compromise 

between WordPress and Drupal [69] In table 4.11, it is made a brief analysis and 

comparison between these three CMS. 

Table 4.11: Brief analysis and comparison between WordPress, Drupal and Joomla!. 

 WordPress Drupal Joomla! 

Ease-of-Use 

It does not require 

technical experience 

and is very intuitive 

and simple to use 

[71] [72]. 

It requires significant 

technical experience 

[71]. 

An intermediate 

knowledge in web 

development 

languages is needed. 

It is less complex 

than Drupal, but 

more than 

WordPress [71] [72]. 

Advantages 

Wide support 

community (plus, 

the larger amount of 

users leads to more 

online questions and 

answers) [69]; it is 

very easy to use in 

the building of a 

simple website [71] 

[72]; it has an 

extensive collection 

of themes and 

extensions [69] [71]. 

It has a powerful 

capability for the 

organization of 

complex content 

[71]; it is capable of 

producing advanced 

websites [71]; it is 

massively scalable 

[73]. 

It is easy to export 

and import backups 

from/to the server 

to/from the localhost 

[72]; it supports e-

commerce and social 

networking [71]; it 

has a good structural 

and code 

organization [72]. 

Disadvantages 

It is difficult to adapt 

complex designs in 

the platform [72]; it 

is not very scalable 

and it is difficult to 

add content once the 

site is complete [74]. 

It is not very user-

friendly [75]; it has 

some compatibility 

issues [76]. 

Of the three, it is the 

one who contains 

less additional 

plugins [74]; there 

are some extensions 

that are free on the 

others CMS, but paid 

in Joomla! [77]. 

Best used for 
Simples websites 

and blogs [71]. 

Complex and 

advanced websites 

[71]. 

Community 

platforms [69] [71]. 

 

It can be considered that Joomla! combines the ease-of-use of WordPress with the power 

and flexibility of Drupal [69]. Thus, it is the best of the three when it comes to create 
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social networks [69] [71] [74], which may be useful in the construction of our platform. 

Therefore, it seems to be the best choice for the development of our platform. 

 

4.4.2 Choice of CMS 

After a meticulous research and a detailed analysis, we concluded that the most 

appropriate tool for the development of our project would be the CMS Joomla!. 

 

 

4.5 Summary 

In this Chapter, we described the main platform requirements and developed a prototype 

to serve as future reference. It was also decided that we would use Joomla! to simplify 

the development of the platform. 
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Chapter 5 

 

Platform Development 

In this chapter, the techniques, tools and solutions used in the construction of the platform, 

taking into account the characteristics previously defined, will be presented. Regarding 

the development of the platform, the version 3.4.8 of Joomla! [78] was used and installed 

on the servers of the Department of Informatics Engineering of the University of 

Coimbra. The version 1.2 of Helix3 Template Framework [79], developed by 

JoomShaper.com, was applied.  

 

5.1 Implementation of Features 

In the subsequent sections, the current appearance and characteristics of the platform will 

be presented and the extensions and tools used in its construction will be described. A 

more detailed explanation of the platform construction methods can be consulted in 

Appendix A. 

In the building of the desired features, margins and paddings were established so that the 

global appearance was considered aesthetically pleasant. In addition, harmonious and 

matching colors were picked; blue was chosen to be the predominant color, since it has a 

calming effect, is related to intellect and can be associated with health [80]. 

For an easier handling of the platform modules, a free version of Advanced Module 

Manager [81] was installed (consult Table A.1). 
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5.1.1 Search Systems 

In the platform, three major search systems are available: a search by topics (by 

anatomical system or physiological context), a search by natural language and a reference 

to the most read/newest contents. 

 

 

Figure 5.1: Homepage. 

 

To enable the search by topics, it is possible to assign one or more defaulted tags to each 

inserted article’s analysis (since an analysis of a scientific paper can address to more than 

one of the defined topics); on the other hand, each topic is associated with a single tag. 

Thus, when we choose a topic (which is associated with a particular tag), all the inserted 

content, associated with that tag, is shown.  

After choosing a topic of one of the two possible fields (anatomical systems or 

physiological context), we are directed to a search results page (Figure 5.2) that has a 

fixed menu, created using Accordeon Menu CK [82], with the possible topics within that 

field. For a more detailed explanation, consult Table A.2. 
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Figure 5.2: Search by topics. 

 

To elaborate a search by natural language, a core feature of Joomla!, called Smart Search, 

was used (consult Table A.3). In this area, it is possible to perform a free search, which 

results are shown if the inserted terms are contained in the submitted analysis. 

 

 

Figure 5.3: Free search results. 

 

Using the SP Portfolio [83] and the SP Tab [84] extensions, the most viewed and the 

newest inserted contents were displayed in the homepage, as shown in Figure 5.1 (consult 

Table A.4). 
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5.1.2 Authentication  

For the login and the logout processes, the Joomla!’s login form and the Quick Logout 

[85] extension were used, respectively. The link to login and logout is available at the top 

of every page of the website. However, the login and logout menu is only displayed, 

correspondingly, to guest users and to registered users. 

 

 

Figure 5.4: Authentication page. 

 

 

 

Figure 5.5: Form for password recovery. 
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At the authentication page, in the case of forgetfulness regarding the password (Figure 

5.5) or username, the user is allowed to complete a questionnaire to recover them.  

More information can be obtained in Table A.5. 

 

5.1.3 User Features 

As seen in the authentication page (Figure 5.4), there is the possibility of creating a new 

account; the new account becomes activated after an e-mail confirmation – the e-mail is 

automatically sent, after the saving of the account. After a user logs in, he is directed to 

his account page, where he has the option to edit his data. There are three levels of users: 

guests, authors and super users. Guests are public users that are not registered into the 

website, while authors and super users are both registered users. When a new account is 

created, that user is considered, by default, an author. 

Super users have special access to a users’ management page, where they are able to look 

at general information of all the users, except for their password. They can also edit other 

users’ data – such as changing their user group – and delete them from the system. These 

functionalities were built using SEBLOD [86] extension.  

 

 

Figure 5.6: User manager. 
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For convenience, a link to this resource (and others forwardly approached) was added to 

an off-canvas menu (the hidden menu previously mentioned), in accordance to the 

restrictions found in Figure 4.1. 

 

 

Figure 5.7: Super users' off-canvas menu. 

 

To view more details, verify Table A.6. 

 

5.1.4 Content Features 

For the creation and the management of content, several Joomla! extensions were used: 

SEBLOD [86] and the free versions of Ark Editor [87], Ark Media Manager [88], Tabs 

[89] and Sourcerer [90] (See Table A.7). 

All the registered users have the option to submit their analyses about scientific papers 

related to physiological processes’ modeling. Pressing “Create an Analysis” in the off-

canvas menu, they are led to a page (Figure 5.8) where it is possible to insert content.  
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Figure 5.8: Insertion of an analysis. 

 

Here, users are able to choose the parameters they want to analyze about the article, as 

well as to create different sections to explore it, using Tabs [89] plugin. An example of 

an analysis can be seen in Figure 5.9.  

 

 

Figure 5.9: Example of an article's analysis. 

 

It is possible to insert code written in HTML, JavaScript and PHP; through Sourcerer [90] 

(Figure 5.10).  
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Figure 5.10: Inserting code in an analysis, using Sourcerer [90] plugin. 

 

In order to perform mathematical calculus and to draw graphical displays of the results 

(as seen in Figure 5.9), two JavaScript libraries may be used: numeric.js [91] and plotly.js 

[92]. To solve ordinary differential equations (ODE), the variable-step numerical method 

of Dormand-Prince can be used, through a numeric.js method. 

To share online content, an iframe can be used. Using Ark Media Manager [88], users 

can insert multimedia content from their devices, such as images (in .jpg, .png, .gif, .bmp, 

.svg, .ico and .tiff format) and files (in .swf, .txt, .rtf, .zip, .pdf, .swf, .fla, .doc, .xls, .ppt, 

.odp, .odt, .html, .xhtml., .xml, .ttf, .woff, .otf, and .eot format).  

Each user has his own personal folder, where they store their files (Figure 5.11). Super 

users can edit and delete all the users’ folders (Figure 5.12). For more information, consult 

Table A.8. 
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Figure 5.11: Example of an author's personal folder. 

 

 

Figure 5.12: Example of a super user's media view. 

 

Since the insertion of articles’ analyses is unrestricted and can be made by any registered 

user, to ensure its quality, all the analyses stay unpublished until a super users’ approval. 

However, authors can edit and delete their own content, at any publishing state (see Figure 

5.13). Consult Table A.9. 
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Figure 5.13: Example of the view of a "My Analyses" area. Each user can see his own submissions. In 

this case, there is only one submission, which is unpublished. 

 

Super users have a special access page in which they can view the inserted content in 

order to evaluate it, with the most recent appearing at the top (Figure 5.14). These features 

were created using SEBLOD [86]. They can also visualize the aspect of the content before 

they approve it (Figure 5.15). 

 

 

Figure 5.14: Article manager. 
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Figure 5.15: Example of an unpublished analysis. 

 

Super users can, moreover, change an analysis’ status to archived. In this case, the 

analyses are not in a published or unpublished state, staying stored. 

For more information, see Table A.10. 

 

5.1.5 Feedback and Discussion 

Any user can rate every inserted article, from one to five stars. When the analysis is 

opened, the mean of the rates is displayed.  

There is also available a discussion forum, created using Kunena [93] (Figure 5.16). Non-

registered users are only able to read the existing topics. Registered users are able to create 

new topics, as well as comment or subscribe other ones. In both cases, if other users 

comment that topic, an e-mail with that information is sent. When creating or commenting 

a topic, there is the possibility to attach an image or a file. Moreover, when a new topic 

was not yet consulted by a user, an indication is shown.  

For more details, consult Table A.11. 
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Figure 5.16: Forum's "Recent Topics" example. 

 

 

5.1.6 Front-end Settings 

Super users are allowed to configure some website options through the front-end, such as 

putting the site offline and changing Search Engine Optimization settings (Figure 5.17). 

For more information, consult Table A.12. 

 

 

Figure 5.17: Super users' website settings. 
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5.1.7 Statistical Analysis 

When a super user logs in, a bar appears at the bottom of the pages, showing some real-

time statistics (using Visitors Counter [94]), such as the website’s visitors number and the 

logged-in users, online guests and registered users (Figure 5.18). Consult Table A.13. 

 

 

Figure 5.18: Statistical analysis. 

 

 

5.1.8 Help Documentation 

To ease the understanding of the features of the platform, a user’s guide is available for 

downloading in the website. The guide is different for authors and super users, being the 

second an extended version. The documentation available for super users can be found in 

Appendix B.   

When operating the platform, if a major action is performed a suitable message is 

exhibited. 
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5.2 Security 

Joomla! CMS offers a strong security [69] [95]. Besides, the construction of the menus 

and the modules was very careful, with special attention to the users’ permissions settings 

and user groups’ accesses. 

Hypertext Transfer Protocol Secure (HTTPS) can be defined as the secure version of 

Hypertext Transfer Protocol (HTTP), a set of rules for transferring files through the World 

Wide Web. In HTTPS, all the communications between the website and the browser are 

encrypted. This protocol is used to safeguard extremely confidential online transactions, 

such as online banking [96] [97].  

The pages of the website that require additional security, (e.g., authentication, inserting 

content, editing personal data, managing users) are accessed exclusively over HTTPS. 

However, as the integration of content from other websites is expected – and they can use 

either HTTP Protocol or HTTPS Protocol – it is necessary that the pages where this 

content is displayed – for example, an article’s analysis – are accessed over HTTP (to 

allow the incorporation of HTTP and HTTPS pages). This change from HTTP-pages to 

secure HTTPS-pages (and vice-versa) was doable using Yireo SSL Redirection [98] 

extension. More information can be found in Table B.14. 

 

 

5.3 Responsiveness 

When selecting the template to apply on the platform, one of the main criteria for the 

selection was its responsiveness. A responsive web design is an approach that generates 

dynamic modifications in the website, depending on the screen size of the device used to 

access it [99].  

Helix Framework Template [79] has a responsive layout and uses Bootstrap 3.2. 

Bootstrap is a free front-end framework that eases web development, such as the design 

of responsive layouts [100]. On the introduction of some content, this tool was used. 
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We were cautious in the structuration of the platform. For example, when dealing with 

small devices, such as smartphones, the search system through natural language no longer 

appears in the homepage (it is presented in the off-canvas menu) and the search by topics 

disappears. The display of the most viewed and newest analyses also changes to smaller 

screens – more information, consult Table B.15. 

Some examples of the platform on different screen sizes can be seen in Figure 5.19.a and 

Figure 5.19.b.  

 

 

Figure 5.19.a: iPhone 6 portrait (width: 375px); Figure 5.19.b:  iPad landscape (width: 1024px) [101]. 

 

The images above were taken using Responsinator [101], a website that checks if an 

online platform is responsive. The Google’s mobile-friendly test (a test to evaluate the 

compatibility of a website with mobile devices) [102] was also performed, achieving the 

result “Impressive! This page is compatible with mobile devices.”. 

 

 

 

 



60 

 

 

 

5.4 Summary 

In this section, the platform functions and key steps of its development were, globally, 

described. We believe that the requirements stated in the previous section were followed 

and the structure of the website and wireframes were respected.  
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Chapter 6 

 

Study Cases 

In this chapter, some examples of content that can be introduced in the platform will be 

presented and studied. Thus, we will analyze some scientific papers about physiological 

modeling and add it to the platform, exemplifying some supported features.  

 

6.1 Scientific Papers about Physiological 

Modeling 

Five scientific papers were selected and analyzed in order to illustrate the platform’s 

features: two are based on works done in CMPP; one is based on a scientific paper that 

explores the features of an online experiment located in the Laboratory of Industrial 

Informatics and Systems of the University of Coimbra; the others are based on scientific 

papers about physiological modeling that seemed interesting to include. 

Many physiological models are built with some complex mathematical operations, such 

as ODEs. After some research, a JavaScript library capable of performing such operations 

was found. As mentioned in Chapter 5.1.4, this library is called Numeric JavaScript [91] 

and provides a lot of useful mathematical operations, listed in [103]. 

The ODE solver included in this library implements the Dormand-Prince-Runge-Kutta 

integrator with adaptive time stepping [103] [104] and it was a very important tool in the 

simulation of the different ODE systems analyzed.  
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For the graphics display, it was used a JavaScript library called plotly [92]. This library 

also allows the download of the graphics as .png, among other features (e.g., zooming, 

select suitable windows).. 

 

6.1.1 Modeling invasion of metastasizing cancer cells to 

bone marrow using ecological principles 

This analysis was based on the scientific paper “Modeling invasion of metastasizing 

cancer cells to bone marrow using ecological principles” by Kun-Wan Chen and Kenneth 

J. Pienta [105] and in an exploration work of the same, done by Catarina Sá Silva and 

Tiago Curado [106] in CMPP. 

For this revision, it was included a glossary of important concepts and explored the 

biological fundamentals of the subject (Figure 6.1). 

 

 

Figure 6.1: Theoretical review of the analysis of [105]. 

 

The mathematical equations presented in [105] were analyzed (Figure 6.2), simulated and 

its results were interpreted. 
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Figure 6.2: Exploration of the algorithm presented in the analyzed scientific paper [105]. 

 

A virtual laboratory that involves one of the discussed topics was also shared (Figure 6.3), 

It was developed by Glencoe/McGraw-Hill [107] and found in [108]. 

 

 

Figure 6.3: Virtual laboratory, developed by Glencoe/McGraw-Hill [107] and found in [108], shared in 

the platform, in the analyzed article. 

 

Finally, the work of Catarina Sá Silva and Tiago Curado [106] was released for download. 

The references of the analysis are also available (Figure 6.4). 

The majority of the introduced content can be found in Appendix C.1. 
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Figure 6.4: References of the analysis made about the scientific paper "“Modeling invasion of 

metastasizing cancer cells to bone marrow using ecological principles” by Kun-Wan Chen and Kenneth 

J. Pienta [105]. 

 

 

6.1.2 Modeling for the drug therapy for HIV infection 

This analysis was based on the scientific paper “Modeling for the drug therapy for HIV 

infection” by P. K. Srivastava, M. Benerjee and Peeyush Chandra [109] and in a work 

grounded on it, done by Baptiste Enes and Joana Rita Santos [110] in CMPP. 

A theoretical analysis of the content was introduced in the platform, including a glossary 

(Figure 6.5) and a review of concepts. 

 

 

Figure 6.5: Glossary of important concepts approached in the analysis of [109]. 
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The mathematical model presented in [109] was analyzed, simulated (Figure 6.6) and its 

results were interpreted. It is possible to download the calculated values of the simulation 

in a .csv file. 

 

 

Figure 6.6: Simulation of the mathematical model of the analyzed scientific paper [109]. 

 

The work of Baptiste Enes and Joana Rita Santos [110] is available for downloading and 

the references of the inserted analysis are shown. 

The majority of the introduced content can be found in Appendix C.2. 

 

6.1.3 A Remote Lab to Simulate the Physiological Process 

of Ingestion and Excretion of a Drug 

This analysis was based on the scientific paper “A Remote Lab to Simulate the 

Physiological Process of Ingestion and Excretion of a Drug” by A. Cardoso, D. Osório, 

J. Leitão, V. Sousa and C. Teixeira [7], which explores the features of an online 

experiment located in Laboratory of Industrial Informatics of the University of Coimbra. 

A review of the literature, the remote laboratory (Figure 6.7) and the references of the 

analysis were introduced in the platform. 
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Figure 6.7: Remote laboratory embedded in the platform, simulating the physiological process of 

ingestion and excretion of a drug. This laboratory is located in Laboratory of Industrial Informatics and 

Systems of the University of Coimbra. 

 

The majority of the introduced content can be found in Appendix C.3. 

 

6.1.4 The Role of Osteocytes in Targeted Bone Remodeling: 

A Mathematical Model 

This analysis was based on the scientific paper “The Role of Osteocytes in Targeted Bone 

Remodeling: A Mathematical Model” by Jason M. Graham, Bruce P. Ayati, Sarah A. 

Holstein and James A. Martin [111]. 

In the theoretical exploration of this scientific paper, a glossary with important concepts 

was introduced, as well as a review of the content. A video, hosted in YouTube and 

created by Amgen [112], was also shared. 

The model algorithm was reviewed, simulated (Figure 6.8) and its results were examined. 

It is possible to export a .csv file of the obtained values. Moreover, in the first graphical 

display, it is allowed to select and unselect the data to show (through their labels). 
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Figure 6.8: Simulation of the mathematical model presented in the analyzed scientific paper [111]. 

 

A virtual experiment (Figure 6.9), developed by Susan Ott and found in [113], was 

allocated in the platform. Furthermore, the references of the inserted analysis were also 

exposed.  

 

 

Figure 6.9: Virtual experiment related to the content of the analyzed article [111]. It was created by 

Susan Ott and found in [113]. 

 

The majority of the introduced content can be found in Appendix C.4. 
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6.1.5 Modeling the Effects of Multiple Myeloma on Kidney 

Function 

This analysis was based on the scientific paper “Modeling the Effects of Multiple 

Myeloma on Kidney Function” by Julia C. Walk, Bruce P. Ayati and Sara A. Holstein 

[114]. 

The theoretical fundamentals of the scientific paper were analyzed. For this, it was 

introduced: a glossary with important concepts, a review of its fundaments and a video, 

hosted in YouTube and created and shared by Armando Hasudungan [115] (Figure 6.10). 

 

 

Figure 6.10: Video shared in the platform. It is hosted on YouTube and created by Armando Hasudungan [115]. 

 

The mathematical model presented in the scientific paper [114] was studied, simulated 

(Figure 6.11) and its results were interpreted. The download of a .csv file with the values 

obtained in the simulation is allowed. The consulted references were also exposed. 
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Figure 6.11: Simulation of the mathematical model presented in the analyzed article [114]. 

 

The majority of the introduced content can be found in Appendix C.5. 

 

6.2 Summary 

This chapter was focused on the display of some case studies that show the different 

features that can be incorporated in the platform. 

Each case study is based on a published scientific paper and its selection followed three 

criteria: the paper is freely accessible online, it is of an interesting physiological subject 

and its theme is substantially different from the others. In this way, it was possible to 

demonstrate the several characteristics of the website. 

As it can be seen, to perform a paper’s analysis, an author has as many options as he 

wants, being able to: choose the content’s organization (for example, which tabs he wants 

to use), insert multimedia sources, upload files and embed code. However, the quality and 

legitimacy of the content is ensured, since all the insertions have to be approved by an 

administrator, before being openly published. 

Summing up, this section showed, through examples, the potential technical interest that 

this platform has, proving its educational use both to people that publish works here, both 

to people that just read the articles. 
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Chapter 7 

 

Test and Validation 

This chapter presents a survey regarding the functionality and usefulness of the platform 

to its target users. Furthermore, the obtained results are explored. 

 

7.1 Overview 

A questionnaire was answered by 58 anonymous students of the Integrated Master in 

Biomedical Engineering of the University of Coimbra, in order to analyze the significance 

of the developed platform. 

The designed survey contains two groups of questions. The first group focuses on 

understanding if the students use to consult digital media as an auxiliary form of study 

and as a mean to overcome their difficulties of learning through traditional teaching and 

studying methods. The second group centers on a practical appraisal of the platform, in 

order to evaluate its helpfulness within the target users and the role that it may have in 

CMPP. 

Given that all the inquired students spoke Portuguese natively, the survey was written in 

that language. Nevertheless, in this chapter, it is presented in English. 
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7.2 Questions and Answers 

In the first group of the evaluation, the users were asked if they have the habit to use the 

Internet to overcome queries and doubts about learning concepts and if they used mobile 

devices to do so. It was also explored if there was a tendency to use digital media to 

understand biomedical subjects and if the questioned targets used to identify struggles in 

practical experimental scenarios that blocked the advantages of learning through them. 

Both the usage of online discussion forums and the utility of a forum within the 

Biomedical Engineering course were also questioned. The questions and answers of the 

inquiry are described below: 

Table 7.1: First question of the first group of queries and respective answers. 

When you have doubts in school contents, do you use to surf on the Internet? 

Answers 

Yes 100% 58 

No 0% 0 

Total 58 

 

Table 7.2: Second question of the first group of queries and respective answers. 

If so, have you ever used you phone or tablet to do so? 

Answers 

Yes 100% 58 

No 0% 0 

Total 58 

 

Table 7.3: Third question of the first group of queries and respective answers. 

Have you ever consulted online websites in order to clarify doubts that you failed to 

understand in school environment? 

Answers 

Yes 98.3% 57 

No 1.7% 1 

Total 58 
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Table 7.4: Fourth question of the first group of queries and respective answers. 

Have you ever used digital contents to better understand certain biological processes 

or other matters related to biomedicine?  

Answers 

Yes 100% 58 

No 0% 0 

Total 58 

 

Table 7.5: Fifth question of the first group of queries and respective answers. 

Have you ever felt, in practical laboratory environments, that you did not have the 

opportunity to get the best out of the practice, for example, because the high number of 

students or because you could not contact directly with the experience? 

Answers 

Yes 86.2% 50 

No 13.8% 8 

Total 58 

 

Table 7.6: Sixth question of the first group of queries and respective answers. 

Have you ever used online discussion forums to look for answers to your questions in 

academic subjects? 

Answers 

Yes 34.5% 20 

No 65.5% 38 

Total 58 

 

Table 7.7: Seventh question of the first group of queries and respective answers. 

If so, do you think that a forum dedicated to questions within Biomedical Engineering 

subjects would be useful? 

Answers 

Yes 95% 19 

No 5% 1 

Total 20 

 

In the second group of questions, after exploring the platform, target users were asked to 

evaluate its features and functionalities. The students that had already attended CMPP 

were inquired, in the context of the course, about its usefulness. The questions and 

answers are shown below. 
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Table 7.8: First question of the second group of queries and respective answers.  

Do you think the platform is easy to use? 

Answers 

Yes 93.1% 54 

No 6.9% 4 

Total 58 

 

Table 7.9: Second question of the second group of queries and respective answers.   

Do you find its overall aspect pleasant? 

Answers 

Yes 98.3% 57 

No 1.7% 1 

Total 58 

 

Table 7.10: Third question of the second group of queries and respective answers.   

Do you consider that the functionalities of the platform are adequate? 

Answers 

Yes 96.6% 56 

No 3.4% 2 

Total 58 

 

Table 7.11: Fourth question of the second group of queries and respective answers.  

Do you consider that the fundament of the platform could help to overcome the 

problems identified in the previous group? 

Answers 

Yes 98.3% 57 

No 1.7% 1 

Total 58 
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Table 7.12: Fifth question of the second group of queries and respective answers. 

From 1 to 5, how do you classify the usefulness of the platform (1 for low usefulness 

and 5 for high usefulness)? 

Answers 

1 0 0 

2 0 0 

3 12.0% 7 

4 55.2% 32 

5 32.8% 19 

Total 58 

 

Table 7.13: Sixth question of the second group of queries and respective answers. 

Would you use the platform in the future? 

Answers 

Yes 93.1% 54 

No 6.9% 4 

Total 58 

 

Table 7.14: Seventh question of the second group of queries and respective answers.  

Have you already attended Computer Models of Physiological Processes?  

Answers 

Yes 82.8% 48 

No 17.2% 10 

Total 58 

 

Table 7.15: Eighth question of the second group of queries and respective answers. 

If so, do you think the platform would help you to better understand the purpose of 

the six-monthly project of the course? 

Answers 

Yes 95.8% 46 

No 4.2% 2 

Total 48 
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Table 7.16: Ninth question of the second group of queries and respective answers. 

If so, do you think that the introduction of those projects in the platform would make 

sense? 

Answers 

Yes 89.6% 43 

No 10.4% 5 

Total 48 

 

 

 

7.3 Results’ Analysis 

The answers obtained in the questionnaire show that the examined students have the habit 

of consulting Internet in order to consult educational content (100%), including to 

overcome doubts that arise in the classroom environment (98.3%). Moreover, all the 

questioned students admitted to use smartphones and/or tablets as a mean to accessing 

this information, which is in accordance to what was expected, given that, as referred 

in[9], people see them as their first choice for connectivity. 

In the last years, driven by the fast development of digital media, there has been a massive 

intensification of the use of multimedia resources in biomedical education [116]. In our 

survey, 100% of the respondents admitted that they have been using digital means to 

better understand biological processes and other contents related to biomedicine. 

86.2% of the questioned students claimed to have experienced difficulties in taking 

advantage of laboratory experimental practices, due to external factors. In this context, 

remote and virtual experiments can be, as discussed in Chapter 2.3, a solution. 

Only 34.5% of the respondents stated that they had used discussion forums to to get 

answers about academic questions. This percentage may be low because it is possible to 

visit forums without asking questions. In fact, the aim of this question was to find out 

how many people consulted forums, considering the ones who make questions and the 

ones that only read other people's dialogues. In our opinion, not all the interviewed 

students understood our intentions. If this was clear, we believe that the rate of "Yes" 

would be much greater, since the finding of an answer in a public forum does not imply 
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that a question was explicitly made (the subject may simply read others' doubts). 

However, 95% of the students that admitted to use discussion forums stated that would 

be useful to have a discussion forum within biomedical engineering. 

After an exploration of the platform, 93.1% of the respondents said that the platform was 

easy to handle, 98.3% think that its appearance is satisfying and 96.6% stated that the 

features of the platform are adequate. When asked to evaluate the usefulness of the 

platform from 1 to 5 (minimum and maximum, respectively), 32.8% of the respondents 

rated it as 5 and 55.2% rate is as 4. 93.1% of the questioned students stated that they see 

themselves using the platform in the future. 

Within the sample of examined students, 82.8% had already attended the course of 

CMPP. 95.8% believe that the platform would have helped to better understand the 

purpose of the six-monthly work. Moreover, 89.6% agree that those works shall be 

inserted in the platform. 

To get a better understanding of respondents' opinion, we analyzed the association 

between different answers. 

We analyzed the answers regarding the usefulness of the platform (from 1 to 5) from who 

admitted to have experienced struggles in laboratory experiment (Figure 7.1) – 50/58 

subjects.  

 

 

Figure 7.1: Answers regarding the usefulness of the platform (from 1 to 5), among the ones who admitted 

to have experienced struggles in laboratory experiments. 

34%

54%

12%

"Yes" in Question 7.5 and "5" in Question 7.12

"Yes" in Question 7.5 and "4" in Question 7.12

"Yes" in Question 7.5 and "3" in Question 7.12
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Though, the trend of the responses is similar to that shown for the entire sample, with the 

"4" being the most chosen value (fulfilling more than a half of the opinions) and the "5" 

being the following one (chosen almost three times more than the mark "3"). 

100% of the respondents that agreed that a discussion forum within biomedical 

engineering would be useful, considered that the functionalities of the platform are 

adequate (Figure 7.2). 

 

 

Figure 7.2: Opinion about the adequacy of the platform's functionalities within the respondents that 

agreed that a discussion forum within biomedical engineering would be useful. 

 

Within the group of respondents who attended CMPP – 48/58 students – 96% indicated 

that the features of the platform are appropriate (Figure 7.3). Again, this value is identical 

to the one obtained in the responses of the entire sample.  

Given that the platform is only in its first version, built from scratch, this is a very positive 

sign for us, validating both our requisites' analysis and the construction of the product. 

100%

0%

"Yes" in Question 7.7 and "Yes" in Question 7.10

"Yes" in Question 7.6 and "No" in Question 7.10
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Figure 7.3: Opinion on the adequacy of the platform, within the group of respondents who attended 

CMPP. 

 

Among the group of people who claimed that the platform would have helped them to 

understand the aim of the CMPP’s project – 46/48 subjects –, 93% indicated that those 

works should be placed on the platform. Despite the fact that this is a higher rate than the 

one obtained within the total amount of answers, we find it peculiar that there are users 

that confess the utility of the platform on the perception of CMPP’s work, but believe that 

those should not be inserted in the platform. 

 

 

Figure 7.4: Opinions about the insertion of CMPP's projects on the website, among the group of people 

who claimed that the platform would help them to understand the goal of the course. 

96%

4%

"Yes" in Question 7.10 and "Yes" in Question 7.14

"No" in Question 7.10 and "Yes" in Question 7.14

93%

7%

"Yes" in Question 7.15 and "Yes" in Question 7.16

"No" in Question 7.15 and "Yes" in Question 7.16
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In general, we believe that the opinions of the target users about the platform were very 

positive, particularly because it is an early version and it already had much acceptance. 

However, in the future, the platform shall be extensively testes, namely is real school 

environment, in order to detect gaps and add other important features. 

 

 

7.4 Summary 

In this chapter, a survey was analyzed to understand some study trends of the students of 

the Integrated Master in Biomedical Engineering of the University of Coimbra. These 

included their use to consult the Internet for educational purposes, their struggles in 

traditional teaching methods and their opinion about the developed platform. 

Most of the inquired students use the Internet to overcome their difficulties, particularly 

through their mobile devices. Furthermore, most of them had already consulted 

multimedia resources to achieve a better comprehension of biological processes and 

admitted to have problems in the achievement of knowledge in laboratory experiments 

due to external agents. Only less than half of the inquired students claimed to use 

discussion forums to clear doubts about educational subjects. Among them, most of all 

agreed that it would be useful to have a forum within the biomedical engineering field. 

On the evaluation of the platform, the majority of the respondents believe that the 

platform is easy to handle, has a nice appearance and has appropriate features. Almost all 

the respondents consider that such a platform could help them overcoming some of the 

difficulties approached in the first group of questions. 

Almost all the students who attended CMPP consider that the platform would ease the 

perception of the course and that the semestral projects should be introduced in the 

website. 
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Chapter 8 

 

Conclusion 

This chapter focuses on a consideration about the project’s final result and in an analysis 

about the future work to execute. 

 

8.1 Final Result 

The main goal of this project was the development of a platform that allowed the storage 

of content based on scientific papers about modeling of physiological processes, 

supported real-time modeling simulations and admitted the sharing of experimental 

scenarios regarding related subjects.  

This project started with a detailed analysis in order to find out which features should the 

platform include and how should them be presented, taking into account the need it was 

facing. Based on this, the design of the platform was planned and all the predictably 

important instruments to its development were studied and analyzed. 

The construction of the platform, from scratch, was the next step, the most challenging 

and the longest one, including the identification of some needed tools, their operation, 

their embedding in the platform and the integration of everything in one single product. 

The creation of a parallel platform in a localhost was an important move here, allowing 

the early testing of many applications and their effects when incorporated in the website. 

The biggest challenges happened, as mentioned, in this stage and concerned, most of all, 

problems related to the integration of the used tools with each other, as well as related to 
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the small amount of completely free extensions available on Joomla!, as discussed in 

Chapter 4.4.1, which eventually hindered the work. 

Fortunately, we did not have to let go any of our pretenses, and all the difficulties were 

overcome. 

After developing the platform, it was filled with some study cases, illustrating its 

functionalities. 

As a final assignment, a survey was delivered to some target users, in order to validate 

the use of the platform. 

All these milestones of the project were planned and all of them were fulfilled. 

We believe that, in the available time, a worthy first version of the platform was created 

and we consider that it reached the desired characteristics. This thesis also reveals that it 

is possible to create a platform with complex functionalities (as our e-learning platform), 

completely free, using CMS Joomla!. 

One of the major advantages of this platform is the possibility of introducing content 

through the front-end, by any registered user, which is a key point to ease its 

implementation in academic means. Besides, this allows the increasing of the repository 

of scientific papers’ analysis and, consequently, enhances the platform’s lifetime.  

In fact, all the operations on the platform are available through its front-end, including 

not only the ones related to authors’ actions, but also the ones that concern the 

management of users and all the platform's content (tasks reserved to super users).  

Moreover, given that the platform is responsive and can be used in any mobile device, 

this may lead to a bigger interest of the users and to amplify the contexts in which it may 

be used.  

Although this project was, undoubtedly, the biggest challenge of my entire academic 

route, it was also the most rewarding. Throughout this year, I had contact with 

technologies that I had never used before and with which I had to deal in order to complete 

this project. I believe that this truly increased my perseverance and work persistence, and 

I am very thankful for that. 
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8.2 Future Work 

In the future, the platform will be tested and validated in a real educational context, in the 

CMPP subject. The benefits and the advantages of blended learning shall also be tested, 

by combining the developed platform with the course traditional teaching methods. 

Subsequently, the writing of a scientific paper that reports these results is planned. This 

step is encouraged by the results of our validity survey, which show that students usually 

value the existence of such technological options in the Biomedical Engineering field. 

The range of features of the platform can also be increased, making it more user-friendly 

and expanding its functionalities. Namely, the platform can be further lengthened to other 

scientific areas, since its structure already allows it. 
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Appendix A 

 

Platform Development Guide 
 

Table A.1: Installation of the Advanced Module Manager [81] extension. 

Extension/ 

Version 
Advanced Module Manager/version 6.1.3 

Type Component/Plugin 

Author Regular Labs (Peter van Westen) 

Implementation Extensions -> Manage -> Select a File -> Upload and Install 

 

 

Table A.2: Main steps of the development of a search by topics. 

First step: creating the desired tags 

Implementation 
Components -> Tags -> New; 

(as an example) Title: “drug ingestion” -> Save 

Second step: creating the topic menus 

Implementation 

Menus -> Manage -> Main Menu -> New; 

(as an example) Details -> Menu Title: “Physiological Context”; Menu Item 

Type -> Tags -> Compact list of tagged items; Tag: [insert all tags 

related to physiological contexts]; -> Save and New; 

(as an example) Details -> Menu Title: “Drug Ingestion”; Menu Item Type  

-> Tags -> Compact list of tagged items; Tag: “drug ingestion”; 

Parent Item -> Physiological Contexts -> Save 

Third step: creating a side menu to appear on the results page, using Accordeon Menu 

CK [82] 

Extension/ 

Version 
Menu Accordeon CK/version 2.0.19 

Type Module 

Author JoomlaCK (Cédric KEIFLIN) 

Implementation 

Extensions -> Manage -> Select a File -> Upload and Install; 

Extensions -> Modules -> New -> Accordeon Menu CK  

(as an example) Module ->Select Menu: “Anatomical Systems”; 

Position: left; Assignments -> Menu Items -> Include -> 

“Anatomical Systems”; -> Save 
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Table A.3: Main steps of the development of the search system by natural language. 

First step: adding a module position in Helix 3 Framework Template [79] layout to 

show the search system 

Implementation 

Extensions -> Templates -> Helix 3 Framework Template -> Layout; 

(as an example) Main Body -> Add Row; 

Settings -> Section Title: “Search”;  

Add Columns -> Custom Layout: 3,9,3; 

Select the middle section -> Module Position -> search -> Save 

Second step: changing some default settings in Smart Search extensions 

Implementation 

Extensions -> Manage -> Manage -> Search for “Smart Search”; 

Disable “Smart Search – Categories”, “Smart Search – Contacts” 

and “Smart Search – News Feeds”; 

Enable “Content Smart Search” -> Save 

Third step: changing some default settings in Smart Search Global Configurations 

Implementation 

System -> Global Configurations -> Smart Search; 

Results Description: Hide; Query Explanation: Hide; Advanced 

Tips: Hide  

-> Save 

Fourth step: creating a page to display the Search Results 

Implementation 

Menus -> Manage -> New; 

(as an example) Title: “Search Results”; -> Save; 

Menus -> Manage -> Search Results -> New; 

(as an example) Details -> Menu Title: “Search Results”; Menu 

Item Type -> Smart Search -> Search -> Save 

Fifth step: creating the Smart Search module 

Implementation 

Extensions -> Modules -> New -> Smart Search 

(as an example) Module -> Title: “Initial Search”; Show Title: 

Hide; Position: search; Search Field Label: Hide; Set Item ID: 

Search Results; Assignments -> Menu Items -> Include -> Home 

-> Save 

  



93 

 

 

 

Table A.4: Main steps of the development of the most read/ newest analysis display in homepage. 

First step: creating the most read and the newest analysis modules, using SP Portfolio 

[83] 

Extension/ 

Version 
SP Portfolio/ version 1.4 

Type Module 

Author JoomShaper.com 

Implementation 

Extensions -> Manage -> Select a File -> Upload and Install; 

Extensions -> Modules -> New -> SP Portfolio 

Module -> Title: “Most Read”; Show Title: Hide; Options -> 

Count:3; Column: 3; Ordering: HITS; -> Save 

Extensions -> Modules -> New -> SP Portfolio 

Module -> Title: “Newest”; Show Title: Hide; Options -> 

Count:3; Column: 3; Ordering: Created Date; -> Save 

Second Step: adding a module position in Helix 3 Framework Template [79] layout to 

show the suggested analysis. 

Implementation 

Extensions -> Templates -> Helix 3 Framework Template -> Layout; 

(as an example) Search -> Add Row; 

Settings -> Section Title: “Suggested Analysis”;  

Add Columns -> Custom Layout: 12; 

Select the section -> Module Position -> position2 -> Save 

Third step: creating the tabs using SP Tab [84] 

Extension/ 

Version 
SP Tab/version 2.0 

Type Module 

Author JoomShaper.com 

Implementation 

Extensions -> Manage -> Select a File -> Upload and Install; 

Extensions -> Modules -> New -> Tab 

(as an example) Module ->Title: “Suggested Analysis”; Show Title: 

Hide; Position: position2; Assignments -> Menu Items -> 

Include -> Home -> Save 
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Table A.5 Main steps of the development of the authentication system. 

First step: installation of Quick Logout [85] Extension. 

Extension/ 

Version 
Quick Logout/version 1.9.3 

Type Component 

Author John Muehleisen 

Implementation Extensions -> Manage -> Select a File -> Upload and Install 

Second Step: creating a menu for login and logout. 

Implementation 

Menus -> Manage -> New; 

(as an example) Title: “Authentication”; -> Save; 

Menus -> Manage -> Authentication -> New; 

(as an example) Details -> Menu Title: “Login”; Menu Item Type -> 

Users -> Login Form; Access: Guests; -> Save; 

Menus -> Manage -> Authentication -> New; 

(as an example) Details -> Menu Title: “Logout”; Menu Item Type -

> Quick Logout -> Quick Logout; Access: Registered; -> Save; 

Third step: editing a module position in Helix 3 Framework Template [79] layout to 

display an authentication menu module 

Implementation 

Extensions -> Templates -> Helix 3 Framework Template; 

(as an example) Basic -> Contact Information: No; 

(as an example) Layout -> Top Bar -> Settings -> Custom Layout: 11,1;-> 

Save 

Fourth step: creating a menu module to display the authentication menu 

Implementation 

Extensions -> Modules -> New -> Menu; 

(as an example) Module -> Title: “Authentication”; Select Menu: 

Authentication; Show Title: Hide; Position: top2; Assignments -

> Menu Items -> Include -> Select All-> Save 
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Table A.6: Main steps of the development of the users’ functionalities. 

First Step: changing users’ global configurations 

Implementation 

System -> Global Configuration -> Users -> Component; Allow User 

Registration:  

Yes; New User Registration Group: Authors; Frontend User 

Parameters: Hide; -> Save 

Second step: installing SEBLOD [86]extension. 

Extension/ 

Version 
SEBLOD/version 3.8.3 

Type Component, Module, Plugin 

Author Octopoos 

Implementation Extensions -> Manage -> Select a File -> Upload and Install 

Third Step: changing SEBLOD’s [86] global configurations 

Implementation 
System -> Global Configuration -> SEBLOD -> Permissions -> Author -

> Delete  

Own: Allowed; -> Save 

Forth Step: changing SEBLOD’s [86] “User” from Form & Content Types 

Implementation 

Construction -> Form & Content Types -> User -> Site Form -> Add 

“User Groups  

(JForm – User Groups)” -> Button 4 -> User Groups (JForm – 

User Groups) – Acess: Super Users; -> Save 

Forth Step: changing SEBLOD’s [86] “User Manager” from List & Search Types 

Implementation 
Construction -> List and Search Types -> User Manager -> List -> Add 

“User  

Groups (JForm – User Groups)” to Column-C -> Save 

Fifth Step: creating menus to access this resources in the off-canvas menu 

Implementation 

Menus -> Manage -> New; 

(as an example) Title: “Social Features”; -> Save; 

Menus -> Manage -> Social Features -> New; 

(as an example) Details -> Menu Title: “My Account”; Menu Item 

Type -> Users -> User Profile; -> Save; 

Menus -> Manage -> New; 

(as an example) Title: “Configuration Manager”; -> Save; 

Menus -> Manage -> Configuration Manager -> New; 

(as an example) Details -> Menu Title: “Add User”; Menu Item Type 

-> SEBLOD-> Form; Content Type: User; Access: Super Users; 

-> Save; 

Menus -> Manage -> Configuration Manager -> New; 

(as an example) Details -> Menu Title: “User Manager”; Menu Item 

Type -> SEBLOD -> List & Search; Search Type: User Manager; 

Access: Super Users; -> Save; 

Sixth step: creating a menu module to display the previously created menus 

Implementation 

Extensions -> Modules -> New -> Menu; 

(as an example) Module -> Title: “Social Features”; Select Menu: 

Social Feature; Position: off-canvas; Assignments -> Menu 

Items -> Include -> Select All-> Save 

Extensions -> Modules -> New -> Menu; 

(as an example) Module -> Title: “Configuration Manager”; Select 

Menu: Configuration manager; Position: off-canvas; Access: 

Super Users; Assignments -> Menu Items -> Include -> Select 

All-> Save 
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Table A.7: Installing the extensions used in the content features. 

Installing Ark Editor [87] 

Extension/ 

Version 
Ark Editor/version 1.8.5. 

Type Component, Plugin 

Author Webx Solution Ltd 

Implementation Extensions -> Manage -> Select a File -> Upload and Install 

Installing Ark Media Manager [88] 

Extension/ 

Version 
Ark Media Manager/version 1.11.0 

Type Component, Plugin 

Author Webx Solution Lt 

Implementation Extensions -> Manage -> Select a File -> Upload and Install 

Installing Sourcerer [90] 

Extension/ 

Version 
Sourcerer/version 6.1.3 

Type Plugin 

Author Webx Solution Lt 

Implementation Extensions -> Manage -> Select a File -> Upload and Install 

Installing Tabs [89] 

Extension/ 

Version 
Tabs/version 6.0.8 

Type Plugin 

Author Webx Solution Lt 

Implementation Extensions -> Manage -> Select a File -> Upload and Install 
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Table A.8: Main steps of the development of the content insertion. 

First Step: changing some Ark Editor [87] global configurations 

Implementation 
System -> Global Configuration -> Ark Editor -> Inline; 

Enable Inline Editing: No; Enable Autosave: No; 

Second Step: changing SEBLOD’s [86] “Article” from Form & Content Types 

Implementation 

Construction -> Form & Content Types -> Article -> Site Form ->  

Article State -> edit ->Default Value: “0”;  

Add “Article Tags (JForm – Tag); -> Save 

Third Step: creating menus to access the creation of an analysis in the off-canvas menu 

Implementation 

Menus -> Manage -> New; 

(as an example) Title: “My Articles”; -> Save; 

Menus -> Manage -> My Articles -> New; 

(as an example) Details -> Menu Title: “Create an Article”; Menu 

Item Type -> SEBLOD-> Form; Content Type: Article; Access: 

Registered -> Save; 

Fourth step: creating a menu module to display the previously created menus 

Implementation 

Extensions -> Modules -> New -> Menu; 

(as an example) Module -> Title: “My Submissions”; Select Menu: 

My Articles; Position: off-canvas; Access: Registered; 

Assignments -> Menu Items -> Include -> Select All-> Save 

 

Table A.9: Main steps of the development of the super users’ article manager. 

First Step: Creating menus to access the Article Manager from the off-canvas menu 

Implementation 

Menus -> Manage -> Configuration Manager -> New; 

(as an example) Details -> Menu Title: “Article Manager”; Menu 

Item Type -> SEBLOD -> List & Search; Search Type: Article 

Manager; Access: Super Users -> Save; 

Second Step: Changing SEBLOD’s [86] CCK Storage Location - Joomla! Article  

Implementation 
Extensions -> Plugins -> CCK Storage Location - Joomla! Article ->  

Default Status: Unpublished -> Save 
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Table A.10: Main steps of the development of the users’ submission content. 

First Step: changing some SEBLOD [86] global configurations 

Implementation 
System -> Global Configuration -> SEBLOD -> Permissions -> Author: 

Delete Own: Allowed; 

Second Step: creating a SEBLOD’s [86] new “List & Search Types” field 

Implementation 

Construction -> List & Search Types -> New -> 

(as an example) Title: “User Submissions”; App Folder: Articles; ->  

Search Form -> Add “Article Created By (JForm-User) -> 

Variation: Hidden; -> Button 2; Live: User; Live Value -> 

Configure -> Properties -> “id”; Add “Article State (Select - 

Simple); Live Value: “0,1,2”; 

List ->Template: “Table – seb_table”;  

List -> Fields -> (s an example) Add “Article Title (text); Add 

“Article Created (Calendar); Add “Article State”; Add “Icon 

Edit”; Add “Icon Delete; -> Save 

Third Step: creating menus to access the creation of an analysis in the off-canvas menu 

Implementation 

Menus -> Manage -> My Articles -> New; 

(as an example) Details -> Menu Title: “My Submissions”; Menu 

Item Type -> SEBLOD-> List & Search Types; Content Type: 

User Submissions; Access: Registered -> Save; 
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Table A.11: Main steps of the development of the forum. 

First step: installation of Kunena [93]Extension. 

Extension/ 

Version 
Kunena/version 4.0.11 

Type Component, Module, Plugin 

Author Kunena Team 

Implementation Extensions -> Manage -> Select a File -> Upload and Install 

Second Step: changing some Kunena’s [93] configurations 

Implementation 

Components -> Kunena Forum -> Configurations ->  

(as an example) General; Enable RSS Feeds: No;  

-> Show Announcements: No; Show Moderators in Category 

Index: No; -> Users; Show Users Statistics: No; Show Karma 

Indicator: No; -> Avatars: Allow Avatar Upload: No; -> Ranking; 

Ranking: No; -> BBCode; Disable Emoticons: Yes; -> Save 

Third step: changing “Kunena – Kunena Integration” [93] plugin 

Implementation 
Extensions -> Plugins -> Kunena – Kunena Integration; Enable Kunena  

Avatars: No; Enable Kunena Profiles: No; -> Save 

Fourth step: disabling some Kunena’s [93] Menu Items 

Implementation 
Menus -> Manage -> Kunena Menu; Disable “Index”, “No Replies”,  

“Profile”, “Help” and “Search -> Save 

Fourth step: creating a menu to access the forum 

Implementation 

Menus -> Manage -> Social Features -> New; 

(as an example) Details -> Menu Title: “Forum”; Menu Item Type -

> Kunena Forum -> Home Page; Default Menu Item: Recent 

Topics -> Save; 
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Table A.12: Main steps of the insertion of front-end settings. 

First Step: Creating menus to access the Configuration Manager from the off-canvas 

menu 

Implementation 

Menus -> Manage -> Configuration Manager -> New; 

(as an example) Details -> Menu Title: “Configuration Manager”; 

Menu Item Type -> Site Configuration Options -> Configuration 

Manager; Access: Super Users -> Save; 

 

Table A.13: Main steps of the development of the statistical analysis. 

First step: installation of Visitors Counter [94] Extension. 

Extension/ 

Version 
Visitors Counter/version 2.0.4 

Type Module 

Author Majunke Michael 

Implementation Extensions -> Manage -> Select a File -> Upload and Install 

Second step: editing a module position in Helix 3 Framework Template [79] layout to 

display the statistical modules 

Implementation 

Extensions -> Templates -> Helix 3 Framework Template -> Layout; 

(as an example) Bottom ->Add Columns -> Custom Layout: 6,6;-> 

Save 

Third step: adding and editing a Visitors Counter [94] module 

Implementation 

Extensions -> Modules -> Add ->Visitors Counter -> Module -> 

(as an example) Show Yesterday: No; Show Digit Counter: No; 

Position: bottom1; Access: Super Users -> Save 

Fourth step: adding and editing a new Visitors Counter [94] module 

Implementation 

Extensions -> Modules -> Add -> Visitors Counter -> Module -> 

(as an example) Show Today: No; Show Yesterday: No; Show 

Week: No; Show Month: No; Show All Days: No; Show Digit 

Counter: No; Show Logged in Users: Yes; Show Guests; Yes; 

Show Registered Users; Yes; Position: bottom2; Access: Super 

Users -> Save 
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Table A.14: Using Yireo SSL Redirection [98] extension. 

First step: installation of Yireo SSL Redirection [98] Extension. 

Extension/ 

Version 
Yireo SSL Redirection/version 0.11.3 

Type Plugin 

Author YIREO 

Implementation Extensions -> Manage -> Select a File -> Upload and Install 

Second Step: changing some Yireo SSL Redirection [98] configurations 

Implementation 

Extensions -> Plugins -> System – SSL Redirect -> SSL Pages -> SSL 

Menu Items:  

“Add User”, “Create an Article”, “My Account”, “Login”, 

“Logout”, “Site Configuration Options”, “User Manager”; SSL 

Components: “com_admin”, “com_login”, “com_quicklogout”; -

> Save 
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Table A.15: Main changes to improve the Platform Responsiveness.  

First Step: adding and editing Helix 3 Framework Template [79] layout (examples) 

Implementation 

Extensions -> Templates -> Helix 3 Framework Template -> Layout; 

Top Bar -> top1 -> Settings -> Tablet Layout: col-sm-10; Mobile 

Layout: col-xs-8; -> top2 -> Settings -> Tablet Layout: col-sm-2; 

Mobile Layout: col-xs-4; 

Extensions -> Templates -> Helix 3 Framework Template -> Layout; 

Search -> Settings -> Hide on Mobile; 

Extensions -> Templates -> Helix 3 Framework Template -> Layout; 

(as an example) Suggested Analysis -> Add Row; 

Settings -> Section Title: “Phone Suggested Analysis”;  

Add Columns -> Custom Layout: 12; 

Select the section -> Module Position -> position5 -> Save 

Second Step: adding a free search system on the off-canvas menu 

Implementation 

Extensions -> Modules -> New -> Smart Search 

(as an example) Module -> Title: “Phone Search”; Show Title: 

Hide; Position: off-canvas; Search Field Label: Hide; -> Save 

Third step: creating the most read and the newest analyses modules, using SP Portfolio 

[83] 

Implementation 

Extensions -> Modules -> New -> SP Portfolio 

Module -> Title: “Most Read”; Show Title: Hide; Options -> 

Count:3; Column: 1; Ordering: HITS; -> Save 

Extensions -> Modules -> New -> SP Portfolio 

Module -> Title: “Newest”; Show Title: Hide; Options -> 

Count:3; Column: 1; Ordering: Created Date; -> Save 

Fourth step: creating the tabs using SP Tab [84] 

Implementation 

Extensions -> Modules -> New -> Tab 

(as an example) Module ->Title: “Suggested Analysis Phone”; 

Show Title: Hide; Position: position5; Assignments -> Menu 

Items -> Include -> Home -> Save 
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Appendix B 

 

User Guide 
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<script 

src="https://cdnjs.cloudflare.com/ajax/libs/numeric/1.2.6/n

umeric.min.js"></script> 

http://www.numericjs.com/
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var sol = numeric.dopri(0,1000,[400, 90, 1, 10],f, 

undefined, 2000); 
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f = function(x,vec) { 

  //definition of constants 

  var gamal = 0.005; 

  var ul = 0.0005; 

  var gamat = 0.005; 

  var gamaf = 0.004; 

  var bp = 0.004; 

  var Ls = 400; 

  var Lt = 100; 

  var up = 0.0035; 

  var ul = 0.0005; 

  var uf = 0.0004; 

  var g1 = 1; 

  var g2 = 1; 

  var g3 = 0.3; 

  var g4 = 0.2; 

  var g5 = 0.5; 

  var g6 = 0.5; 

 

 

  //definition of the differential equations 

  var P = vec[0]; 

  var L = vec[1]; 

  var T = vec[2]; 

  var F = vec[3]; 

 

  var dP = bp*Math.pow(l,g1)*Math.pow(P, g2)-up*P-

gamaf*Math.pow(L, g3)*Math.pow(P, g4); 

  var dL = gamal*Math.pow(T, g5)*Math.pow(L, g6)-ul*L; 

  var dT = gamat*T*Math.log10(Lt/T); 

  var dF = gamaf*Math.pow(L, g3)*Math.pow(P,g4)-uf*F; 

 

 

  return [dP, dL, dT, dF]; 

} 
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<script src=" https://cdn.plot.ly/plotly-

latest.min.js"></script> 

<html> 

<div> 

<object data="your url" width="1200" height="1000"> 

<embed src="your url" width="1200" height="1000"> </embed> 

Error: Embedded data could not be displayed. 

</object> 

</div> 

</html> 

https://plot.ly/javascript/line-charts/
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https://www.sublimetext.com/3
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<!DOCTYPE html> 

<html lang="en"> 

<head> 

<meta charset="utf-8"> 

<script 

src="https://cdnjs.cloudflare.com/ajax/libs/numeric/1.2.6/n

umeric.min.js"></script> 

<script src="https://cdn.plot.ly/plotly-

latest.min.js"></script> 

</head> 

 

<body> 

 

<button onclick="calculo()" type="button" class="btn btn-

info">RUN</button> 

 

<script> 

window.onload = function(){ 

  grafico1([], []); 

  grafico2([], []); 

  grafico3([], []); 

  grafico4([], []); 

} 

 

calculo = function() { 

    var sol = numeric.dopri(0,1000,[400, 90, 1, 10],f, 

undefined, 2000); 

    var vector1=[]; 

    var vector2=[]; 

    var vector3=[]; 

    var vector4=[]; 

 

    for (var i = 0; i < sol.y.length; i++) { 

 

      vector1[i] = sol.y[i][0]; 

      vector2[i] = sol.y[i][1]; 

      vector3[i] = sol.y[i][2]; 

      vector4[i] = sol.y[i][3]; 

    } 

    solucao = [sol.x, vector1, vector2, vector3, vector4]; 

 

    grafico1(solucao[0], solucao[2]); 
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    grafico2(solucao[0], solucao[4]); 

    grafico3(solucao[0], solucao[3]); 

    grafico4(solucao[0], solucao[1]);  

  } 

 

f = function(x,vec) { 

  //definition of constants 

  var gamal = 0.005; 

  var ul = 0.0005; 

  var gamat = 0.005; 

  var gamaf = 0.004; 

  var bp = 0.004; 

  var Ls = 400; 

  var Lt = 100; 

  var up = 0.0035; 

  var ul = 0.0005; 

  var uf = 0.0004; 

  var g1 = 1; 

  var g2 = 1; 

  var g3 = 0.3; 

  var g4 = 0.2; 

  var g5 = 0.5; 

  var g6 = 0.5; 

 

 

  //definition of the differential equations 

  var P = vec[0]; 

  var L = vec[1]; 

  var T = vec[2]; 

  var F = vec[3]; 

 

  var dP = bp*Math.pow(l,g1)*Math.pow(P, g2)-up*P-

gamaf*Math.pow(L, g3)*Math.pow(P, g4); 

  var dL = gamal*Math.pow(T, g5)*Math.pow(L, g6)-ul*L; 

  var dT = gamat*T*Math.log10(Lt/T); 

  var dF = gamaf*Math.pow(L, g3)*Math.pow(P,g4)-uf*F; 

 

 

  return [dP, dL, dT, dF]; 

}  

</script> 

 

<div class="container-fluid"> 

  <div class="row"> 

   <!--  FIRST COLUMN --> 

    <div class="col-sm-6"> 

     <div id="myDiv1" style="width: 50%; height: 50%;"><!-- 

Plotly chart will be drawn inside this DIV --></div> 

      <script>  

grafico1 = function(a, b) { 
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     fazerPlot1(a,b,'Graphic 1','time t 

(days)','Free Light Cell Population', 'myDiv1'); 

    } 

      </script> 

    </div> 

 

<!--  SECOND COLUMN --> 

    <div class="col-sm-6"> 

     <div id="myDiv2" style="width: 50%; height: 50%;"><!-- 

Plotly chart will be drawn inside this DIV --></div> 

      <script>  

grafico2 = function(a, b) { 

     fazerPlot1(a,b,'Graphic 2','time t 

(days)','Fibroblasts Population', 'myDiv2'); 

    } 

      </script> 

    </div> 

 

<!--  THIRD COLUMN --> 

    <div class="col-sm-6"> 

     <div id="myDiv3" style="width: 50%; height: 50%;"><!-- 

Plotly chart will be drawn inside this DIV --></div> 

      <script>  

grafico3 = function(a, b) { 

     fazerPlot1(a,b,'Graphic 3','time t 

(days)','Tumor Cells Population', 'myDiv3'); 

    } 

      </script> 

    </div> 

 

<!--  FOURTH COLUMN --> 

    <div class="col-sm-6"> 

     <div id="myDiv4" style="width: 50%; height: 50%;"><!-- 

Plotly chart will be drawn inside this DIV --></div> 

      <script>  

grafico4 = function(a, b) { 

     fazerPlot1(a,b,'Graphic 4','time t 

(days)','Proximal Tubules Cell Population', 'myDiv4'); 

    } 

      </script> 

    </div> 

  </div> 

</div> 

 

<script> 

function fazerPlot1(a,b,titleGraph,titleX,titleY, janela){ 

 var trace = { 

        x: a, 

        y: b, 

        mode: 'lines+markers', 

        marker: { 
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           color: 'rgb(41, 203, 209)', 

            size: 3 

        }, 

        line: { 

            color: 'rgb(41, 203, 209)', 

            width: 1 

        } 

    }; 

    var data = [trace]; 

    var layout = { 

        title:titleGraph, 

        xaxis: { 

            title: titleX 

        }, 

        yaxis: { 

            title: titleY 

        }, 

        height: 500, 

        width: 400 

        }; 

       Plotly.newPlot(janela, data, layout); 

 } 

  </script> 

 </body> 

</html> 

 

  



119 

 

 

 

  



120 

 

 

 

 

  



121 

 

 

 

 

 

Appendix C 

 

Case Studies: Analyses 

 

C.1 Analysis of “Modeling invasion of 

metastasizing cancer cells to bone marrow 

utilizing ecological principles” [105] 

 

C.1.1 Theoretical Approach 

 

C.1.1.1 Glossary 

Ecosystem: This describes a system of interconnected elements within a bounded area, 

and the dynamics that are created among them. In biological terms, it includes a biological 

community of living beings (the biotic component) and all the non-living (physical and 

chemical) elements that are presented in their surrounding environment (the abiotic 

component) [117] [118]. The network of interactions that exists between the several parts 

of these components (dynamic over space and time) is the one that establishes the 

“system”. The boundaries of an ecosystem are specified simply for practical reasons. The 
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study of an ecosystem is mainly focused on the study of the mentioned processes, which 

usually comprise energy transformations and biogeochemical cycles [118]. 

Population biology: It covers the study of populations of organisms and the existing 

relationships, both among themselves and between them and the environment. This 

concerns the tracking of population changes (related, for example, to population size, 

historical events, diseases, overcrowding, extinction, etc.) and the underlying processes 

that lead to that [119], dealing with genetic, physiological, demographic and age 

heterogeneities [120]. 

Ecological niche: This describes the position of a population in its environment or 

habitat, showing the way it responds to external factors, as well as the way it is affected 

by them. These factors may be abiotic components, food and shelter resources, 

competitors or predators, for example [121] [122]. This leads to the evolution of the 

population in the niche, since all these factors affect the survival and reproduction of the 

individuals [121]. 

Intraspecific competition: The individuals of a population have similar needs in terms 

of survival, growth and reproduction, which may lead to demands for resources that 

exceed the existing supplies. In this case, the individuals of the same species will compete 

for the resources among them (intraspecific competition). This scenario may influence 

innumerous events, such as: decreased rates of resource intake per individual, decreased 

rates of individual growth or development, decreases in the amounts of stored reserves, 

increased risks of predation, decreases in survivorship and decreases in fecundity [123]. 

Interspecific competition: It may cause, in a population, the same fecundity, growth and 

survivorship consequences of the last concept, but, in this case, the resource exploitation 

or interference is made by individuals of other species. As seen, this phenomenon affects 

the populations’ dynamics, and the dynamics, in their turn, can influence, over time, the 

species’ distributions and their evolution in the environment [124]. 

Hematopoietic stem cell niche: Hematopoietic stem cells are a subpopulation of 

hematopoietic cells capable of differentiating to all blood cell lineages. Their 

characteristic of having a long-lived self-renewal ensures the generation of blood cells 

throughout life. These stem cells are mostly located in the bone marrow, surrounded by a 

specific microenvironment, called the hematopoietic stem cell niche. This niche provides 

protection and plays a role in signaling the start of the stem cells’ differentiation [125]. 
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Bone marrow: Located in the hollow spaces inside bones, bone marrow is a soft, spongy 

and gelatinous tissue that consists of the two main types of stem (undifferentiated) cells, 

supported by a fibrous tissue called stroma. The bone marrow may, then, be red or yellow, 

depending on whether it consists of mainly red-colored hematopoietic tissue or yellow-

colored fatty tissue. The first one is involved in producing blood cells, whereas the other 

is involved in producing stromal cells [126]. 

Metastasis: Cancer cells from a metastatic cancer have the ability of breaking away from 

a tumor in the primary site and spreading to other parts of the body, both by moving into 

nearby normal tissues and by moving through the bloodstream and lymph system to more 

distant sites [127] [128]. When some of these cells are able to settle in the new location 

and to grow and form new tumors, it is said that a metastasis occurred [88]. 

 

C.1.1.2 Content Review 

A niche can be considered a space occupied by an organism in an ecological community. 

Similar species tend to reside in similar niches [129]. When the niches of two different 

species overlap, an interspecific competition occurs, which is a competition of two 

species for the same resources [130] [131].  

An invasive species can be defined as an organism that causes ecological damage in an 

ecosystem where it is not native [132]. The invasive species can either die or settle in, 

starting to propagate and creating impact on the new environment, causing consequences 

to the native species [105]. 

It is possible to make an analogy between invasive species and cancer metastasis, once 

cancer cells grow in a place, escape and survive until they reach a new tissue (i.e., new 

environment) [105]. Thus, in this context, the following analogy may be made: 
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Figure C.1: Analogy between invasive species and metastasizing cancer, grounded on Tilman's model. Adapted from 

[105] [106]. 

 

 

C.1.2 Computational Simulation 

 

C.1.2.1 Algorithm Analysis 

The following analysis is based on what is referred and reported in [105]. The symbols 

used in the equations and their meaning are in Table D.1, which was transcribed from 

[105]. 

Table C.1: Symbols used in the equations of [105]. Transcribed from [105]. 

Symbol Definition 

ρ1 Density of species 1 

ρ2 Density of species 2 

β1 Birth rate of species 1 

β2 Birth rate of species 2 

µ1 Death rate of species 1 

µ2 Death rate of species 2 

k 
The ability (proportion) that species 1 can displace species 2 by the growth 

(birth) of species 1 

v 
The ability (proportion) that species 2 can displace species 1 by the growth 

(birth) of species 1 

t Time 
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In Tilman’s model [133], a superior species can occupy the niche of an inferior species. 

However, an inferior species can only colonize an environment that is not occupied 

neither by itself nor by the superior species [105] [106].  

𝜕𝜌1

𝜕𝑡
=  𝛽1𝜌1(1 − 𝜌1) −  µ1𝜌1     (𝟏)

𝜕𝜌2

𝜕𝑡
=  𝛽2𝜌2(1 − 𝜌1 −  𝜌2) −  µ2𝜌2 −  𝛽1𝜌1𝜌2     (𝟐)

In the Equation 1, it is seen that the proliferation of the superior species (species 1) 

depends only on its birth and death rate. Observing the Equation 2, it is seen that the birth 

and death rates of the inferior species (species 2) are dependent on the competitive 

interactions between the two species [105] [106]. 

Kun-Wan Chen and Kenneth J. Pienta adapted the Tilman’s model of invasion dynamics, 

considering that the invaders are the tumor cells and that the hematopoietic stem cells 

(HSC) are already in the bone marrow [105] [106]. As seen in Tilman’s unmodified 

model, the superior species is not affected by the inferior species. However, when 

modeling the real dynamics between HSC and tumor cells, it is difficult to understand 

which is the superior and inferior species and it shall be taken into account that they both 

have the capability to displace each other [105] [106]. 

𝜕𝜌1

𝜕𝑡
=  𝛽1𝜌1[1 − 𝜌1 − (1 − 𝑘)𝜌2] −  µ1𝜌1 −  𝛽2𝜌2𝜌1𝑣     (𝟑)

𝜕𝜌2

𝜕𝑡
=  𝛽2𝜌2[1 − (1 − 𝑣)𝜌1 −  𝜌2] −  µ2𝜌2 −  𝛽1𝜌1𝜌2𝑘     (𝟒)

It was considered that k = 0.9 and v = 0.1, which indicates that the tumor cells displace 

90% of the HSCs and the HSCs displaces 10% of the tumor cells [105]. In the simulations 

performed in the platform, it was considered the following values for the graphic 1, 

graphic 2 and graphic 3, according to what was simulated in [105]: β1 = 0.2, β2 = 0.8, µ1 

= 0.1 time-1, µ2 = 0.1 time-1. The initial values may be changed in the simulation. 

 

C.1.2.2 Simulation 

A computational simulation was performed and displayed in the platform, taking into 

account the previously discussed equations. 
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C.1.2.3 Results Interpretation 

The graphics obtained are identical to those presented in [105]. 

The first graphic analyzes the Tilman’s unmodified equations, to the dynamics between 

tumor cells and HSCs. HSCs are considered to be the superior species. As expected, the 

colonization of the superior species (HSCs) is completely independent of the behavior of 

the inferior species (tumor cells). After the local density of the HSCs stabilizes, the 

density of the tumor cells also tends to a constant value. The lower is the initial local 

density of HSCs, the sooner will the local density of tumor cells tend to stabilization. In 

this case, the initial values for local density were always higher for HSCs and near zero 

to tumor cells.  

The second graphic presents the Tilman’s unmodified equations, to the dynamics between 

tumor cells and HSCs, in which tumor cells are considered the superior species. Again, 

the behavior of the superior species (tumor cells) is independent of the inferior species 

(HSCs). The local densities of both species tend to stabilize. Although the initial values 

for local density are higher for HSCs (inferior species) and nearby zero to tumor cells 

(superior species), the stability values for the local density are higher to tumor cells than 

to HSCs cells. 

In the third graphic, the Kun-Wan Chen and Kenneth J. Pienta adapted Tilman’s model 

of invasion dynamics is analyzed. In this case, it is taken into account that both species 

have influence on each other. Tumor cells are considered to be the superior species. In 

this perspective, as expected, the graphical behavior of one influences the other’s 

behavior. Although tumor cells are still the superior species and the initial values are 

identical, unlike the previous case, the local density of tumor cells does not surpass the 

density of HSCs, although the density of the superior species increases and the inferior 

species decreases. Again, the densities tend to stabilize. 
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C.1.3 Experimental Procedure 

A virtual laboratory, studying how the competition affects the growth of a population, 

was shared in the platform. The reference to the laboratory was found in The Biology 

Corner [134]. It was created by Glencoe/McGraw-Hill [107] and can be found in [108]. 

 

 

C.2 Analysis of “Modeling for the drug 

therapy for HIV infection” [109] 

 

C.2.1 Theoretical Approach 

 

C.2.1.1 Glossary 

Human Immunodeficiency Virus (HIV): A lentivirus – a subgroup of retrovirus –

composed by two single chains of Ribonucleic Acid (RNA) and envelope proteins. HIV 

attacks, gradually, the immune system, destroying a type of white blood cells, CD4 + T 

cells, by making copies of itself inside them [135] [136] [137] [138]. 

Immune System: The immune system is a collection of cells, tissues and organs that 

protect the body against diseases and infections. When functioning properly, it detects 

threats – as viruses, bacteria and parasites, distinguishing them from the body’s tissue, 

and fights these pathogen agents [139]. 

Acquired Immunodeficiency Syndrome (AIDS): It is a syndrome caused by HIV virus, 

when a person’s immune system is too weak to fight and the organism becomes 

vulnerable to many diseases and infections. When the number of CD4 + T cells drops 

below 200 cells per millimeter of blood, they are said to have AIDS [135]. 
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CD4+ T Cells: CD4+ T cells are a type of white blood cells that are vital to human 

immune responses as they coordinate the activity of other T-cells subsets, B-cells and 

innate immune responses. CD4+ T cells have specific membrane receptors; after they 

recognize pathogen agents, bound to macrophages, dendritic cells or B cells, they 

stimulate the activity, differentiation and expansion of other immune cells, through the 

production and release of chemical compounds [110] [138] [140] [141]. 

Reverse Transcriptase (RT) – Enzyme encoded in retroviruses that catalyzes the 

transcription of the retrovirus’ RNA into deoxyribonucleic acid (DNA). This is the 

reverse process of what occurs in cellular transcription, in which DNA is transcribed into 

RNA [142]. 

 

C.2.1.2 Content Review 

Immunity can be defined as our body’s way to protect us from infections and diseases. 

When our body is infected with pathogen agents, such as viruses and bacteria, the immune 

system fights those organisms and substances [110] [143]. As a consequence, the 

following time our body meets the same organism, we will be immune to that infection, 

which means that we will be less likely to get that disease or, if we do, it will be less 

intense [144]. 

CD4+ T cells, also known as T-helper cells, are possibly the most important cells in 

adaptive immunity, once they are required for all immune responses [145]. This type of 

white blood cells plays a major role in protecting our body, by sending signals to activate 

our body’s immune system when invaders are detected, controlling other T-cell subsets, 

B-cells and innate immune response [141] [146]. Consequently, our CD4+ T cells count 

– number of CD4+ T cells per cubic millimeter of blood – provides an indication of the 

health of our immune system [147] [148]. A normal CD4+ T cells count range from 500 

to 1600 cells per cubic millimeter of blood [146].  

HIV attacks the immune system, especially the CD4+ T cells. AIDS is the final stage of 

HIV infection, when the immune system becomes badly vulnerable. When the number of 

CD4+ T cells drops below 200 cells per cubic millimeter of blood, a person is considered 

to have AIDS [149]. There is still no definitive cure for HIV, but there are ways to control 

it, such as antiretroviral therapy [149]. 
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Once HIV is inside the cells, the virus releases its RNA and RT turns the virus’ RNA into 

DNA, becoming this DNA into the cell [150]. 

 

 

Figure C.2: HIV replication cycle. Taken from [151]. 

 

RT can be blocked by RT inhibitors [152]. Thus, drugs such as RT inhibitors have been 

used to control HIV, given that they can prevent the reverse transcription of the virus 

[153]. 
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C.2.2 Computational Simulation 

 

C.2.2.1 Algorithm Analysis 

The following analysis is based on what is referred and reported in [109] and explored in 

[110]. The symbols used in the equations, their meaning and their value are in Table 1, 

which was transcribed from [109]. 

Table C.2: List of parameters used in the simulation of [109]. Transcribed from [109]. 

Parameter Definition Value 

s Inflow rate of CD4+ T cells 10 mm-3 days-1 

k Interaction-infection rate of CD4+ T cells 
0.000024 mm3 

days-1 

µ CD4+ T cells natural death 0.01 days-1 

η Effectiveness of reverse transcriptase inhibitor 0.6  

α 
Transition rate from pre-RT infected CD4+ T cells 

class to productively infected class (post-RT) 
0.4 days-1 

b 
Reverting rate of infected cells to uninfected class 

due to non-completion of reverse transcriptase 
0.05 days-1 

µ1 Death rate of infected cells 0.015 days-1 

δ Death rate of actively infected cells 0.26 days-1 

N 
Total number of viral particles produced by an 

infected cell 
1000 

c Clearance rate of virus 2.4 days-1 

 

This mathematical model corresponds to the dynamics of HIV on the effect of RT 

inhibitor. The equations to be simulated are [109]: 

𝑑𝑇

𝑑𝑡
= 𝑠 − 𝑘𝑉𝑇 −  𝜇𝑇 + (𝜂𝛼 + 𝑏)𝑇1

∗     (𝟏) 

𝑑𝑇1
∗

𝑑𝑡
= 𝑘𝑉𝑇 − (𝜇1 +  𝛼 + 𝑏)𝑇1

∗     (𝟐) 

𝑑𝑇∗

𝑑𝑡
= (1 − 𝜂)𝛼𝑇1

∗ −  𝛿𝑇∗     (𝟑) 

𝑑𝑉

𝑑𝑡
= 𝑁𝛿𝑇∗ − 𝑐𝑉     (𝟒) 
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There are three types of CD4+ T-cells populations: Equation 1 represents the susceptive 

CD4+ T-cells; Equation 2 represents the infected CD4+ T-cells, before reverse 

transcriptase – pre-RT cells; Equation 3 represents the infected CD4+ T-cells, after 

reverse transcriptase – post-RT cells, and that are able to produce the virus; and Equation 

4 represents the virus density [109] [110]. 

The initial conditions presented in the scientific paper for the mathematical model, and 

used in the simulation, are: T(0) = 300 mm-3, T1
*(0) = 10 mm-3, T*(0) = 10 mm-3 and V(0) 

= 10 mm-3. Some of the constants can be changed in the simulation, according to what 

was performed in the article. 

 

C.2.2.2 Computational Simulation 

A computational simulation of the mathematical model presented in [109] was simulated, 

according to the previously approached conditions. 

 

C.2.2.3 Results Interpretation 

The graphics obtained are identical to those presented in [109].  

Through the simulation, we see that the greater is the effectiveness of RT inhibitor (η), 

more pre-RT infected cells become uninfected and less pre-RT cells become post-RT 

cells. Consequently, the greater η is, the more effective is the treatment [109] [110]. 

The lower is the transition rate between pre-RT and post-RT CD4+ T cells (α), less pre-

RT cells become post-RT cells. Consequently, the lower α is, the more effective is the 

treatment [109] [110]. 

When the rate of infected to uninfected CD4+ T-cells due to non-completion of the 

reverse transcriptase (b) is zero, no cell is converted from infected to uninfected. 

However, the greater b is, more infected cells become uninfected. Consequently, the 

greater b is, the more effective is the treatment [109] [110]. 

 

 



132 

 

 

 

C.3 Analysis of “A Remote Lab to Simulate 

the Physiological Process of Ingestion and 

Excretion of a Drug” [7] 

 

C.3.1 Theoretical Approach 

 

C.3.1.1 Literature Review 

The scientific paper focus on the explanation of a remote experimental system presented 

in the Laboratory of Industrial Informatics and Systems of the University of Coimbra, 

constituted by the Amira’s DTS200 three-tank system [154]. 

The simulation consists of a fluidic system and the liquid (supposed drug) that flows 

within the device is water. The need for three interconnected tanks comes from the fact 

that each of them mimics one anatomical structure, in the following order: intestines (tank 

1), bloodstream (tank 2) and bladder (tank 3). The links between the tanks represent the 

interactions between the organs (including the kidneys, which are considered as transition 

elements). Furthermore, the input of the system is the drug intake that flows to tank 1, 

and its concentration in each tank is then variable through time, depending on different 

conditions that may be defined by the user [7] [155] [156]. 

Figure 1, taken from [7], is a scheme of the division of the three-tank system. 
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Figure C.3: Scheme for the division of the three-tank system. Taken from [7]. 

 

 

C.3.2 Experimental Procedure 

The remote laboratory, regarding the three-tank system located in the Laboratory of 

Industrial Informatics and Systems of the University of Coimbra that simulates the 

physiological process of ingestion and excretion of a drug, was shared in the platform. 
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C.4 Analysis of “The Role of Osteocytes in 

Targeted Bone Remodeling: A 

Mathematical Model”  

 

C.4.1 Theoretical Approach 

 

C.4.1.1 Glossary 

Osteocytes: Most abundant bone cells, inserted in the bone [157]. They produce type I 

collagen and other substances to form the extracellular matrix [158]. 

Pre-Osteoblasts: Mesenchymal cells that develop into osteoblasts [159]. They secrete 

osteoid, an organic non-mineralized part of the bone matrix that is produced before the 

maturation of the bone [160]. 

Osteoblasts: Large bone cells, found in the surface of bones, responsible for the synthesis 

and mineralization of bone formation and bone remodeling. They can differentiate into 

osteocytes [158] [161]. 

Osteoclasts: Large multinucleated bone cells, descendent from stem cells, responsible 

for the bone resorption. They occupy small depressions on the surface of the bone [158] 

[162]. 

Bone Remodeling: Regulated process of resorption by osteoclasts followed by 

replacement of new bone by osteoblasts [163] [164]. 

Bone Resorption: Stage of the bone remodeling process where the old bone is broken 

down and absorbed [165]. 

Sclerostin: Formed primarily by osteocytes, it inhibits the bone formation and stimulates 

apoptosis of osteoblasts [166]. 
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Receptor Activator of Nuclear Factor κ-B Ligand (RANKL): It binds to the Receptor 

Activator of Nuclear Factor κ-B (RANK) on osteoclast precursors and leads to the 

maturation of osteoclasts. It is secreted by osteoblasts [167]. 

Osteoprotegerin (OPG): Receptor secreted by osteoblasts and sequesters RANKL, 

inhibiting osteoclast [167]. It is produced by differentiated osteoblastic cells [111]. 

Wnt/β-catenin pathway: A signaling pathway that stimulates pre-osteoblasts’ 

replication and osteoblastogenesis and inhibits osteocytes and osteoblasts’ apoptosis 

[168]. 

 

C.4.1.2 Content Review 

Bone remodeling, a process that undergoes continuously through life, involves the 

removal of old bone by osteoclasts followed by the formation of bone matrix through the 

osteoblasts [164] [169] [170]. Thus, it can be defined as an active process that balances 

the bone resorption and the bone formation [167]. 

Bone resorption is assured by active osteoclasts, which are, in normal conditions, 

stimulated by RANKL. On the other hand, bone formation is achieved by inhibiting 

osteoclasts, through OPG, and stimulating osteoblasts [167]. 

 

 

Figure C.4: Bone remodeling. Taken from [170]. 
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Until recently, not much attention was given to the role of osteocytes in bone remodeling. 

However, as discussed in [111], there is increasing evidence that it has a fundamental role 

secreting sclerostin and being also a source of RANKL [111].  

It has been suggested that sclerostin is a major mediator in bone remodeling, through two 

opposite mechanisms: high sclerostin levels can lead to an antagonization of Wnt/β-

catenin signaling pathway and direct to bone resorption; low sclerostin levels can activate 

Wnt/β-catenin signaling pathway and lead to bone formation [171]. 

 

C.4.1.3 Multimedia Resources 

It was inserted in the platform a video that explains the process of bone remodeling. The 

video is hosted on YouTube and was created and shared by Amgen [112]. 

 

 

C.4.2 Computational Simulation 

 

C.4.2.1 Algorithm Analysis 

The following analysis is based on what is referred and reported in [111]. The symbols 

used in the equations, their definition and their values are in Table 1, which were 

transcribed from [111]. We will focus our analysis, and following simulation, on the 

baseline case presented in [111]. 
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Table C.3. The parameters used in the equations and their definition and values [111]. Transcribed from 

[111] 

Parameter Definition Value 

α1 Osteoblast embedding rate 0.5 per day 

α2 
Differentiation rate of pre-osteoblast 

precursors 
0.1 per day 

α3 Pre-osteoblasts proliferation rate 0.1 per day 

β1 Differentiation rate of pre-osteoblasts 0.1 per day 

δ Apoptosis of pre-osteoblasts 0.1 per day 

β2 Osteoblast apoptosis 0.1 per day 

α4 
Differentiation rate of osteoclasts 

precursors 
0.1 per day 

KS Critical value of osteocyte population 200 cells 

k1 Bone resorption rate 0.7 % volume per day 

k2 Bone formation rate 
0.015445 % volume per 

day 

g31 
Effectiveness of osteoblast autocrine 

signaling 
1 (dimensionless) 

g21 
Effectiveness of osteocyte paracrine 

signaling of osteoblasts 
2 (dimensionless) 

g22 
Effectiveness of sclerostin regulation of 

osteoblastogenesis 
1 (dimensionless) 

g32 
Effectiveness of pre-osteoblasts autocrine 

signaling 
1 (dimensionless) 

g41 
Effectiveness of osteocyte paracrine 

signaling of osteoclasts 
1 (dimensionless) 

g42 
Effectiveness of sclerostin regulation of 

osteoclastogenesis 
1 (dimensionless) 

g43 
Effectiveness of osteoblast paracrine 

signaling of osteoclasts 
-1 (dimensionless) 

g44 
Effectiveness of sclerostin regulation of 

osteoclastogenesis 
1 (dimensionless) 

f12 
Effectiveness of pre-osteoblast paracrine 

signaling of osteoblasts 
1 (dimensionless) 

f14 
Effectiveness of osteoclasts paracrine 

signaling of osteoblasts 
1 (dimensionless) 

f23 
Effectiveness of osteoblasts autocrine 

signaling for apoptosis 
1 (dimensionless) 

f34 
Effectiveness of osteoclasts autocrine 

signaling for apoptosis 
1 (dimensionless) 
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Jason M. Graham, Bruce P. Ayati, Sarah A. Holstein and James A. Martin established a 

cell population model for osteocyte-induced targeted bone remodeling. This resides in an 

osteocyte, a pre-osteoblast, an osteoblast and an osteoclast cell population, the 

interactions of these cells and the relation of the autocrine and paracrine signaling among 

these cells [111]. 

𝑑𝑆

𝑑𝑡
=  𝛼1𝐵𝑔31  (1 −

𝑆

𝐾𝑆
 )

+

     (𝟏) 

𝑑𝑃

𝑑𝑡
=  𝛼2𝑆𝑔21 (1 −

𝑆

𝐾𝑆
 )

+

𝑔22

+  𝛼3𝑃𝑔32 (1 −
𝑆

𝐾𝑆
 )

+

−  𝛽1𝑃𝑓12𝐶𝑓14 − 𝛿𝑃      (𝟐) 

𝑑𝐵

𝑑𝑡
=  𝛽1𝑃𝑓12𝐶𝑓14 −  𝛽2𝐵𝑓23 − 𝛼1𝐵𝑔31 (1 −

𝑆

𝐾𝑆
 )

+

    (𝟑) 

𝑑𝐶

𝑑𝑡
=  𝛼4𝑆𝑔41𝑃𝑔42(𝜀 + 𝐵)𝑔43  (1 −

𝑆

𝐾𝑆
 )

+

𝑔44

−  𝛽3𝐶𝑓34   (𝟒) 

𝑑𝑧

𝑑𝑡
= −𝑘1𝐶 + 𝑘2𝐵     (𝟓) 

Equation 1, Equation 2, Equation 3 and Equation 4 describe the dynamics, respectively, 

of the osteocyte, pre-osteoblast, osteoblast and osteoclast cell population at a time t. 

Equation 5 defines the bone mass at a given time t [111]. 

The initial conditions presented in the scientific paper for the mathematical model, and 

used in the simulation, are: S(0) = KS – ρ, where ρ>0 is a constant that denotes the 

osteocytes apoptosis, P(0)=B(0)=C(0) and z(0)=200 [111]. 

 

C.4.2.2 Computational Simulation 

A computational simulation of the baseline case, approached in [111], was implemented 

and demonstrated in the platform, according to the parameters previously mentioned. 
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C.4.2.3 Results Interpretation 

The simulations presented in [111] were replicated for the baseline case and the graphics 

obtained are identical to those displayed in the scientific paper. 

The graphics show the simulation results for bone cell populations and the dynamics of 

bone volume during a complete bone remodeling that occurs over a period of one hundred 

days, in which the bone resorption is equal to the bone formation [111]. 

Graphic 1 shows the dynamics of all cell populations. The level of osteocytes is initially 

low, representing the cells’ apoptosis and the subsequent decreasing in local sclerostin 

levels, which leads to the proliferation and differentiation of pre-osteoblasts. The 

differentiation of these pre-osteoblasts leads to the increasing of the number of 

osteoblasts. This goes along with the differentiation of osteoclast precursors to mature 

osteoclasts. Once the bone remodeling finishes, all the cell population go back to their 

initial values, except for osteocytes, which remain in their steady state value [111]. 

Graphic 2 represents the dynamics of bone volume, illustrating the resorption and 

formation of bone. As it can be seen, and because of the aforementioned, the old bone 

resorption is equal to the new bone formation, at the end of the process [111]. 

 

C.4.3 Online Experiment 

An animation, showing the process of bone remodeling, was inserted in the platform as 

an online experiment. It was created by Susan Ott and can be found in [113]. 
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C.5 Analysis of “Modeling the Effects of 

Multiple Myeloma on Kidney Function”  

 

C.5.1 Theoretical Approach 

 

C.5.1.1 Glossary 

Multiple Myeloma: Cancer formed in plasma cells, a type of white blood cells [172] 

[173]. 

Monoclonal Free Light Chains: The earliest biomarkers in malignant plasma cell-

proliferative disorders [174] [175]. 

Tubulointerstitial fibrosis: Process initiated by the interaction of free light chains 

(FLCs) and tubule cells, causing inflammation on the kidneys [114]. Regular end-stage 

for renal diseases [176]. 

Fibroblasts: Active cells of connective tissue, responsible for synthetizing collagen and 

extracellular matrix [177] [178]. 

Proteinuria: High concentrations of protein in the urine [179]. The overflow of 

proteinuria can be related with an enlarged production of light chains in multiple myeloma 

[180]. 

 

C.5.1.2 Content Review 

Multiple myeloma is a form of cancer that affects the plasma cells, a type of white blood 

cells located in bone marrow. When cells become malignant, they overproduce a protein 

that grows and takes over the bone marrow, blocking the action of healthy cells [181]. 
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Figure C.5: Healthy bone marrow and bone marrow in multiple myeloma. Taken from [182]. 

 

Although it has been given more attention to how multiple myeloma affects the bone, it 

is also important to examine how it affects the kidneys [114]. Fast evolution of tumor 

cells inhibits the bone rebuilding and they begin to degenerate, which can cause 

proteinuria, once it is released high amounts of calcium and proteins to the bloodstream, 

instigating kidneys to overwork and consequent failure [181]. 

The protein that leads to this damage is called monoclonal immunoglobulin (Ig) light 

chain (also named M protein). It is a subunit of the antibodies, which are produced to 

combat infections. Tumor plasma cells overproduce this protein, leading to the most 

common cause of severe renal failure, tubulointerstitial pathology, resulting from the high 

concentration of Ig light chains. However, not all the FLCs are toxic to the kidneys, 

appearing this to be related to its structure or protein folder [114]. 

FLCs can be noxious to proximal tube cells (PTCs) by activating tubulointerstitial 

fibrosis, an inflammation that causes the excess accumulation of extracellular matrix, 

which may be replaced for scar tissue – which is largely irreversible. This process leads 

to the damage of proximal tubule cells and end stage renal disease [114] 

 

 



142 

 

 

 

C.5.1.3 Multimedia Resources 

A video that describes multiple myeloma was embed in the platform. The video is hosted 

on YouTube and was created and shared by Armando Hasudungan [115]. 

 

 

C.5.2 Computational Simulation 

 

C.5.2.1 Algorithm Analysis 

The following analysis is based on what is referred and reported in [114]. The following 

table, transcribed from [114], shows the list of parameters used in the simulation, as well 

as its meanings and values.  

Table C.4: List of parameters used in the simulation [114]. Transcribed from [114]. 

Parameter Definition Value 

γL FLC growth constant 0.005 cells-1 days-1 

γT Tumor growth constant 0.05 days-1 

γF Fibroblast growth constant 0.004 dL/(mg days) 

βP PTC proliferation constant 0.004 days-1 

LS FLC saturation constant 400 mg/dL 

LT Maximum tumor size 100 (maximum percentage) 

µP PTC natural apoptosis rate 0.0035 days-1 

µL Natural FLC apoptosis rate 0.0005 days-1 

µF Natural fibroblast apoptosis rate 0.0004 days-1 

g1 Strength of inhibited FLC on PTC growth 1 (dimensionless) 

g2 Strength of PTC on its own growth 1 (dimensionless) 

g3 Strength of FLCs on PTC growth 0.3 (dimensionless) 

g4 Strength of PTC on its own death 0.2 (dimensionless) 

g5 Strength of tumor on FLC growth 0.5 (dimensionless) 

g6 Strength of FLC on its own growth 0.5 (dimensionless) 

 

The authors chose to use Gompertz model to model the evolution of multiple myeloma 

[114]. 
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𝑑𝑃

𝑑𝑡
=  𝛽𝑃 (1 −  

𝐿

𝐿𝑆
)

+

𝑔1

𝑃𝑔2 −  𝜇𝑃𝑃 −  𝛾𝐹𝐿𝑔3𝑃𝑔4      (𝟏) 

𝑑𝐿

𝑑𝑡
= 𝛾𝐿𝑇𝑔5𝐿𝑔6 − 𝜇𝐿𝐿     (𝟐) 

𝑑𝑇

𝑑𝑡
= 𝛾𝑇𝑇𝑙𝑜𝑔 (

𝐿𝑇

𝑇
)     (𝟑) 

𝑑𝐹

𝑑𝑡
= 𝛾𝐹𝐿𝑔3𝑃𝑔4 − 𝜇𝐹𝐹     (𝟒) 

Equation 1, Equation 2, Equation 3 and Equation 4 describe, respectively, the population 

of proximal tubule cells, the amount of free light chains, the tumor density and the 

populations of fibroblasts, at time t [114]. 

The initial conditions presented in the scientific paper for the mathematical model, and 

used in the simulation, are: P(0) = 400,  L(0) = 90, T(0) = 1 and F(0) = 10 [114]. 

 

C.5.2.2 Computational Simulation 

A computational simulation was performed and displayed in the platform, taking into 

account the previously discussed equations. 

 

C.5.2.3 Results Interpretation 

In this simulation, the forms of our graphics follow the ones showed in the paper [114]. 

However, there is a difference in the evolution through time of the graphics, since, in our 

simulation, a little greater time interval is needed to reach the same values as in [114]. 

The behavior of the graphics is consistent to what was expected. As the density of the 

tumor cells increases, the FLCs amount and fibroblasts population rises and the 

population of proximal tubule cells falls [114]. 
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